Qolsys 1.6.2 Photo Frame App

I upgraded my panel to 1.6.2 (I think, about shows 6.3 as a version info) over the weekend, which I know wipes photos and changes the file size specs, but did this update also change photo resolution limits? I still had the resized photos on my PC from when I originally loaded them, all sized to 800x480 or less, and all under 400k in size. However, when I put these back on a card and attempt to load to the frame, it errors out saying all photos are larger than 800x480. Are they still supposed to be in a folder named Photos or just on the root of the card? And is 800x480 still the max resolution or did that shrink?

From the official release notes:

“New and existing systems will default the PhotoFrame display type setting to “Weather/Clock”
Removed all custom photos from existing systems to clear any overs-sized photo media files
Reduced custom photo individual file size limit from 1MB to 400KB maximum
Changed display during Armed Away state to only show Qolsys Home screen”

I don’t believe any other changes occurred. Can you verify there is nothing on the card larger than 400k?

Yeah, definitely none larger. And I even shrank the resolution down a little just in case. Error still says greater than 800x480.

Just to verify, none of them are using portrait dimensions, correct? All landscape? I haven’t heard this and will send it to Qolsys to look into.

Have you tried loading a single image and seeing if it will accept it?

Will try a single tonight. A couple of them are portrait, but scaled to the right dimensions, and were on the panel before. So unless they changed that too, don’t think they’re our culprit either. So just as a note, I still have the files from when I originally loaded them. Checked and all are 800x480 or less, and the largest file size among them is 285k.

Same result with a single picture. I’m going to try formatting the SD card just in case.

Any luck with reformatting?

Also, Qolsys states no known issues regarding photo frame as long as the requirements are followed.

Instead of “Photos” try adding one landscape image to a folder called “DCIM”

Any luck?

Sorry, forgot to update this thread. Formatting did do the trick. Think the folders were the culprit, but it’s strange. I had a DCIM folder (card was from a camera), but it was completely empty. I created a Photos folder on the root per instructions. So even though the only pictures were in the photos folder, the mere presence of the DCIM folder, even empty, seems to throw it for a loop. Once I wiped it, I still used the Photos folder, and the panel found and re-loaded them without issue.