Problem with new Yale YRD240 lock

Hi. I’m having some problems with a new yale z-wave (YRD240) lock. It is not consistently reporting its status to the 2gig panel.

ADC shows the lock, and it responds to commands pretty consistently, but ADC does not show the battery status and if I manually toggle the lock, it doesn’t seem to ever update its status.
When I go into z-wave toolbox and pull up the device to edit it, most of the time it fails to retrieve z-wave device status. With the panel right next to the lock it wouldn’t consistently retrieve z-wave status either.

Is there any way to check errors on your end to see if there is something telling?

I’ve tried the normal procedures like placing the panel right next to the lock for enrollment, leaving it there for 5 min and then doing a network discovery after moving the panel back to its normal location. There is a repeater wall switch within 6 feet of the lock. I have removed it from the network and re-added it.
There is another YRD240 lock within 5 feet of this new one and it is acting normal.


Hmm. Based on the troubleshooting you have done already, this may point to an issue with the lock itself. However, one hiccup in the learn process for a lock can cause headaches down the line.

In diagnostics for the network, I do see a few messages reported to have no transmission route, but it looks like they were acknowledged on further attempts. And it is only a few. The network has nearly 100% communication.

I’ve manually requested an update from that lock and it looks like battery status is now showing up. Can you test a little and see if status updates the same as your other lock?

You guys are great! Thanks Jason.
It is showing the battery status now, but I’m still not getting accurate lock status. It showed “Unlocked” just now when it really was physically locked.
This at least gives me hope and I’ll watch it for a few days to see if something changes before returning the lock. The other locks initially had some problems showing me a correct lock status, and they seem to have settled down. So maybe this will sort itself out.
Are you thinking that something inside the lock may not be reporting the correct status to the z-wave module, or something like that?

The most telling part of what you initially described is the inability to access the lock’s controls and pull status at the panel.

The lock may still have had a communication hiccup during enrollment. Commonly when you try to learn in a lock and the process succeeds but remote features seem sluggish or unresponsive it is actually still a problem with enrollment. (less likely here since it sounds like you did it following all directions and suggestions, but I’ve seen stranger things)

I would have originally suggested maybe replacing the AA batteries in the lock prior to enrolling again, just in case, but now that we see battery status, it reports over 91%.

I would still enroll it once more myself, just to rule out enrollment issues.

If it is a problem with the lock or the lock’s module, there is no real way to determine that except by ruling everything else out. It is always possible, of course, but usually least likely.

Is there anything different about this lock’s location? More metal nearby? Is the interior portion with battery housing in a temperature controlled environment?

The environment is a little different, but I don’t think that’s a factor. This is an exterior door into the detached woodframe garage. The only other radio device in the garage is the opener, and this is Houston, so the temperature hasn’t gone below about 50 deg. There’s a z-wave switch in the exterior brick wall beside the back door, which is >6 feet from this lock.
I first enrolled this lock on the kitchen counter before even installing it (using recommended procedures with the 2gig panel next to it on the counter). And then ran it like that for about a day before moving it to he door.
The issues didn’t change when I moved the lock to its permanent location. Then, when the ADC battery status didn’t show up on day-2 I unenrolled it and enrolled it again. I’ll try to enroll it one more time before giving up on it.
Thanks again.

I see. From your description (and if all other devices respond to your panel normally) then I would guess the lock behaving differently would have more to do with the lock.

You could try adding another repeating device between the panel and that general area of the home where the lock is located to ensure a route for signals. The diagnostics don’t suggest many problems, but there were messages that couldn’t find a route, likely to that lock.

If trying a different lock is not a hassle, that may be the proper step though.

Thanks. If it doesn’t improve in the next couple days I’ll just return it.
There is another switch between the locks and the 2gig:
Many, many thanks for running this excellent forum (and the videos and other resources…). I can’t think of the last time I was happier with a supplier than I have been with suretydiy.

You are very welcome. Thank you as well. We’re glad to hear that!

Well, I have some improvement! I tried your suggestion and re-enrolled it ‘just one last time’ and it is behaving much better now. I’m not sure if this is significant, but it gave it a new node ID this time. Seems like it kept the same device ID the previous times I reenrolled it.
I now have good status updates, and it usually succeeds in querying z-wave device status. Not 100%, but most times it will acquire the device status when queried from the panel.
ADC is consistently reporting the correct lock status, but battery status is gone again. Could you request a device status and see if we can get that going again?

Updated the status, let us know if the battery level doesn’t show up.