Photo Frame - IQ Panel 4 - Adding Your Own Photos

I don’t think the IQ Panel 4 has a Micro-SD card slot, so am I correct in assuming the only way to add your own photos is to utilize an Android Phone over Bluetooth?

Any way to add photos by using a website? or an iPhone?


Correct, the only way to transfer photos would be through an Android device via Bluetooth at this time.

Just to clarify, can this be done via Bluetooth on iPhone or just android phones?

The only way to transfer photos would be through an Android device via Bluetooth. iPhone is not supported at this time.

Support was added for transfer of images via the built in access point in the IQ Panel 4 in version 4.1

Great news.

Just to clarify, does this mean I can use my iphone?

And If I am using a PC, do I need a cable or something?

are there instructions on how to add photos that you can post?

I just upgraded to 4.1 and tested this out. Process is as follows: Go into the Photo Frame → Add → Tap on the dropdown menu that is the display group and choose “Panel AP”. Tap on “Start” to start the Panel AP, which will bring up the following on the screen.

You can manually connect to the SSID (such as if you want to use PC/Mac) or scan the QR code if using a mobile device to have it automatically join.

The second QR code will take you to the web page of the panel AP, or just enter the address manually.

A basic website loads where you can browse for photos.

Once you are done stop the panel AP. You may need to confirm your device (PC/Mac/Mobile) switched back to your preferred WiFi network as well. Even though the panel WiFi network is now off, your device may still be stuck to it.


Good instructions here from the prior poster.

No you do not need a cable. You connect via the AP mode of the IQ Panel. (your device uses the IQ Panel as its wifi access point.)

What size / dimension to the photos need to be to not be distorted?

I’m not aware of any specific issue regarding image quality, but to best assist can you send us a private message with an image of the panel screen showing the distortion you are referencing, as well as confirmation of the resolution of that photo so that we can test?

Looks like the specs for the LCD resolution are 800x480 pixels. Based on that, cropping my images to a 5:3 aspect ratio seems to do the trick. :slight_smile:

1 Like

Is this working for the rest of you?

I’m able to connect to the panel wifi access point, I can bring up the web page. I select photos to upload, and it uploads them. At that point…I can’t find them on the panel. What am I missing?

Also - anyone know what the magic number of maximum photos is? The Qolsys 2 used to allow 20. When I try to upload 20, it just says I’ve passed the maximum…but it doesn’t say what the maximum is.

I’m doing this from a PC fwiw. On my iPhone it won’t load the page in Firefox or Safari.


I am able to successfully upload an image via an Android device at this time (AP Mode)

I did this from my PC using Firefox and while I had to confirm that i indeed wanted to access the site, I was able to upload and send an image this way as well.

Both images show up in the main area of Settings > Photo Frame

Thanks, got it working. I tried a different computer, and it seemed to work better. Qolsys definitely has some room for improvement, though!

Agreed. I like the feature but it feels like an afterthought. Especially if you don’t have Android

Many thanks to HDClown for the writeup—it worked for me! If anyone runs into Jim’s problem of being unable to upload more than a few photos: go back and delete the existing, stock photos the panel came with. Those count against the total! It took me way too long to figure that out. You should see a “select all” option, and you can tap on any photos you want to keep to un-select them, then delete the rest all at once. Then you can upload to your heart’s content (well, I’m sure there’s a maximum amount).

I was able to do this all on my iPhone, by the way. Safari wouldn’t let me load that page due to some kind of safety issue, but I was able to convince Chrome to load it (it also gave me a warning page, but there was an “advanced options” link, which gave me the option to “load anyway” or something similar).