PG9303 Sensors with DSC Neo - Can't Enroll

I just activated with you today and that went very smoothly. I’m now in the 7 day test mode period with and am still adding some sensors to my DSC Neo system. (I have a previous separate adt system that I"m turning off and moving some of the hardwired connections over).

However, I’m having trouble enrolling some PG9303 sensors with the DSC Neo. I had purchase 10 or so and the first two I did several days ago and had no problems. But then today I went to enroll the remainder and when I pull the battery tab out, the Neo panel does not see the device and repopulate the id. If I type in the id of the PG9303 sensor (tried the remaining 8), it says the “device not found/invalid” and does not recognize them.

Are there any quirks / issues with this particular sensor that anyone knows of that might cause this? I saw with a particular DSC motion sensor that you had to modify the id number slightly due to some firmware version issue.

I have a DSC Neo V1.3 and the PG9303s say firmware 1.7.

I don’t know of any specific issues with those sensors.

Are the two that learned in without trouble a different firmware version?

Can you open the PG9303’s that aren’t working and make sure the battery is inserted with the proper polarity? (Also check to make sure the battery tab came out cleanly and there isn’t any debris blocking the connection.

Thanks for your fast response. I was able to resolve this. Not sure why the auto-population of the device id was not working the first time.

I opened one of the sensors up and removed the battery and then put it back in. The keypad then auto-entered the device id and then after that I was able to do the same to the other sensors that I needed to enroll and enrolled them all.

I did discover something that explains why these did not work when i manually keyed in the device id# from the sensor. On the sensor the device id#s all start with 109-xxxx,

However when detected by the keypad and the number is entered for me, they all show 100-xxxx. So that explains why when I manually tried to enter the device#s they did not work.

Not sure why the discrepancy but that info might help someone else if they have this same difficulty.

thanks again.

I am sorry to hear it was troublesome, but I am glad you got this resolved!

Interesting that the tab removal originally did not work, but yes, opening and reinserting the battery will duplicate the effect. Let us know if you have any other issues!