Panel Communication Issues

About 2 months ago I ordered a Verizon communicator module and monitoring service to takeover an existing Vivint Panel. The panels software is version 1.9.6. After installing the module and adding a few sensors all was working well until about 3 days ago.

My system is unresponsive to ARM/Disarm commands from both the mobile app and website. Sometimes the command will not go through for several hours. When I check the radio status is shows 28/31 for signal strength and the connection status goes from connected (OTASP OK) to idle then trying to connect then connected again. On the next page Error says command aborted. When I run a cell phone test it will either pass or sometimes won’t pass until it resets the radio. After the radio test passes all the remote commands come through to the panel. The problem just recently started.

After reading on this forum I have:
1 Power Cycled the panel
2 Reseated the Cell Module
3 New Antenna
4 Moved Panel
5 Reset Panel

Any suggestions would be greatly appreciated. Thanks…

How do you currently have the panel/communicator/antenna installed?

I do see the last few signal readings yesterday were incredibly low, and I am unable to get a response currently.

Make sure you aren’t using an older, small antenna and that you have the in-wall antenna attached.

This issue is likely more related to the carrier network than your equipment. We have seen similar circumstances before. So far a couple things have been true:

  1. Temporary issue, usually resolved by carrier involvement regarding one of their towers.
  2. Have not seen it occur again in the same location.
  3. Affects inbound, not outbound communication.

I’m reporting this one to ADC to look into ASAP. When you verify the correct antenna is attached, can you run a cell test quick?

I currently have the in wall antenna that came with the new cell module I purchased from you guys attached. I ran a tell test just now. I was showing 14/31 signal strength and connection idle during the test the radio reset and now I have 31/31 signal strength and shows connected.

I don’t believe it is a cell tower issue as we have 4 verizon cell phones in the house that all have great signals aND no data issues. I will be leaving for work in about an hour. I work about 35 miles away from my house and have great cell reception there. I can take the panel with me and see if the communication is any better there if that will help.

I don’t believe it is a cell tower issue as we have 4 verizon cell phones in the house that all have great signals aND no data issues.

It isn’t technically a signal strength issue that I am referring to.

It is an issue which in the past seems to correlate with tower software upgrades. We haven’t really seen it lately. Again, it only affects inbound comms.

Another thing that might be causing an issue: do you happen to have a VZ cell network extender in your house?


I do have a network extender. I did not think that would cause an issue as I had it installed with the network extender for over a month with no issues. I did take the panel with me over to my fathe-in-laws house last night and had the same issue. I was getting a 20/31 signal and he does not use a network extender.

Here is a link to a video a took just now when the alarm panel won’t respond to a mobile command. I sent the last mobile command 15 minutes ago.

Sorry I forgot to paste the link. Here it is.

Moving the panel from place to place is not a recommended way to test. Signal strength readings from last night are showing between 1 and 8 strength, and signal strength takes a little while to register properly.

Cell network extenders, if your panel modules internal phone number is not added to the extender’s whitelist, can cause an issue where your panel module tries to repeatedly connect to the extender as the closest source, but is denied, so it will jump to another tower. However, it can do this thousands of times a day.

It results in outbound commands being routed through available towers when connected, but inbound commands having no inbound route as it is constantly changing. See this thread.

The very first troubleshooting step would be to add your panel to the extender whitelist.

The serial number on your module is not the number needed. Please email and reference this thread and our customer service team can send you the appropriate number to add to the whitelist.

I received the module phone number from customer support and added it to my network extender. I will test it over the next few days and report the results back to you.

I do have one other question. I factory reset my panel to try and troubleshoot this issue. I am going to start reprogramming all my sensors back in. Do you need to do anything on your end so all the sensors will be monitored and match up with the sensors on I will hold off on reprogramming them until I know for sure. Thanks.

Reprogramming sensors will repopulate with the new sensors and names from the panel.

I would suggest letting us run a restore from your panel backup, but it looks like an automatic backup occurred early morning (around 4am) today. I am assuming this was after you had defaulted?

It was after I reset the panel. I will get them programmed back in. So far the panel seems to be accepting mobile commands OK. It still shows going from connected to idle and back to connected. Is that normal?

Yes, that is common.

Looks like signal strength requests are responding quickly and show highest possible signal strength now.

I had a few more problems yesterday with the panel not responding to mobile commands but after a reboot of both the network extender and then the panel everything is working great now. Thank you very much for all the help.

Not a problem. If you notice any further issues, definitely let us know. So far, as far as I am aware, this has resolved all similar issues in the past.