No power supply detected

I have a Qolsys 4 panel that I just opened and went through the wizard and it is saying that it is not connected to ac power and the power supply is plugged in. I am using the barrel connector.

I am sorry to hear that but I am happy to assist!

Is the panel currently powered on with the cable connected or is it running off of battery only?

Are you able to navigate to Settings > Advanced Settings > Power Down?

If so, do that, then unplug the power supply from the wall, open the panel and disconnect the internal battery. Ensure that the power cable is connected securely at the panel and power supply.

Leave the system off for about 2 minutes then power the panel up battery first, then power supply. Turn on the panel and wait 5 minutes or so for the panel to boot up. Once on does the issue resolve?

If not, be sure to try a different, non-switched, outlet

It’s running with the cable plugged in but it says there is no ac power. And I also tried other outlets, I disconnected the battery and it still doesn’t recognize a power adapter is connected. I know the outlet works fine.

I tried what you said and the issue is still there, can I get a replacement unit?

Can you send a photo of the main panel screen?

No I already packed it up and I’m at work. It is not recognizing the ac adapter and with out it I can’t use this panel, I would like to return it for a replacement please thank you. The main screen comes up and says the panel has issues that need attention and the power supply says no ac power.

I have reached out to the manufacturer to make sure there is nothing else that can be attempted to resolve the issue. As soon as I have that information I will follow up here and will include warranty replacement instructions as necessary.

Thank you.

any word yet? I have no alarm as of now.

No follow up at this point in the day, likely wont hear anything until tomorrow.

Does the panel power up with the power supply but no battery?


I don’t understand why this is becoming difficult, I self monitor and as of yesterday i cant, this is becoming an issue for me. can i speak to someone instead of typing. i have no system that i am paying for.

Surety support is performed online. We do not offer phone tech support.

There is nothing particularly difficult, but some troubleshooting questions are necessary. There are conditions that can cause this such as incorrect wire polarity. Generally the manufacturer needs us to rule these out before an RMA can be issued. Looks like we reached out to them for any potential known issues.

If you are using the provided wiring, the striped wire is positive for the barrel connector. That striped wire must be connected to the positive terminal on the power supply. Please check this.

Yes I checked, the polarity is correct.

I got into an icon that says dc input voltage test and dc input voltage is 0.0.

can you see the panel on your end? I tried to do a firmware update but it wont let me because the ac adapter is not recognized and it wont update on battery power.

Thank you for that information. We have heard back from Qolsys and replacement is recommended at this time. I will be following up with more information on how to proceed via Private Message .