No "Codes" Button on Panel with Schlage Lock

I recently added a Schlage BE369 lock to my 2gig panel and am trying to add user codes. I’m still awaiting the arrival of my unlocked GSM module, so I don’t have access through the portal at this time. Therefore, I am trying to use the panel to add user codes to the lock. Following the directions from the install guide I go to the “Change Door Locks Settings” screen, but there is no “Codes” button on the bottom right when I select the lock. Is it a problem in discovery that causes this (I have removed the lock from the panel and readded it twice)? I can’t seem to figure out what I’m doing wrong…

FYI – The lock is discovered as: “IR Sec. & Safety” The panel does show the correct locked/unlocked status and I can unlock it from the panel as expected.

Running firmware 1.10.1? Firmware 1.10 added supported for schalge zwave, and 1.10.1 added some more fixes. If you are going to use schlage, make sure you are running newest panel firmware.

I am running 1.10.1… So, that shouldn’t be it!

Check question 79 in the programming. In order to program the locks locally, you’ll have to have it set to (2). This will allow local control of the Z-Wave devices. Once you have access to, you will need to change Question 79 to (3) in order to have remote access to your Z-Wave devices.

Jay… OK… One problem solved (thanks!) on to the next thing! So, I can now access the codes button, but the panel only allows me to add a “Master” code, there’s no options for additional user codes when I get in to the screen. It appears that a Schlage lock should allow up to 19 users. Is this another setting that I’m missing?

Again, thanks for your help!

You will have to setup user codes on the panel before you can apply codes to the lock. If you only have the master code setup on the panel, only the master code will be available to change for the lock.

Jay… Once again you are the man with answers. Thank you for your support. Really looking forward to a long relationship with Surety…