No cell test on menu screen

I just installed an LTEV1-A-GC2 in my GC2 panel because the cell card that I had previously purchased was one that was no longer being activated.

This is supposed to be a Verizon 4G LTE Cell Radio and when I input the IMEI number it returned a response indicating is was able to be activated.

After installation and reboot of the panel, there is no cell test option as there should be. I’ve powered down, removed the battery, reseated the module, and plugged everything back in but still nothing there.

The panel boots normally. It is showing to be at Firmware V1.19.

Any suggestions would be appreciated. I started my plan today and was following the steps and am now stuck at the cell phone test step.

Just to be sure, what menu are you looking in, and are you using the installer code or the master code to access the menu?

What do you see under the Radio Status menu? (In the Installer toolbox, accessed via the bottom right corner logo on the home screen)

It would be good to try updating to the latest version downloadable here:

Thanks for your response.

My panel is a new never activated self-installed panel with the default installer code 1561.

I’m going to toolbox and version to determine:

IOP: 110.2014
Build: 16329
Radio Modem: 6189

There is no “Radio Status” menu.

I’m fairly certain I need to upgrade the firmware from 1.19 to but there doesn’t seem to be a way to upgrade firmware if I cannot get the radio module to activate.

The other radio module I have is a 3G model that is no longer being activated so I’m guessing trying to use that isn’t an option either since that module cannot be activated.

According to the documentation the LTEV1-A-GC2 (Verizon Cat 1) should work with firmware 1.19. If you have the 2GIG-LTEA-A-GC2 (AT&T) then you would need firmware 1.19.3.

If you don’t already have the panel connected the only way to upgrade firmware is to use the USB update cable.

It’s worth a shot to upgrade if you’re willing to buy the cable and do the work but it’s not a guarantee. It’s also possible that you could have a bad module. You might want to consider getting the cable and a new module and just send back the new module if you don’t need it.

I contacted Amazon and they sent a replacement LTEV1-A-GC2 but there is still no Radio Status button to press after I press the 2Gig logo in the lower right hand corner and enter the 1561 installer code.

I realize I have my sensors programmed and my fobs programmed etc.

Would there be any benefit at all to doing a factory reset on the panel and trying to start over?

I installed a 2gig GC2 system at my previous house with no issues but I was just reading about Q’s 43,44, 45. Since my panel was a new never activated, not company branded panel, do I have to worry about these?

I don’t want these to be the wrong values and have something bad happen.

Thanks in advance.

Q 91 needs to be set to 1 in panel programming. Is it? This governs the radio modem supplier, 1 is

Q 43 governs installer code, 1561 is factory default
Q 44 locks out programming. Default is 0 (no lockout) and should be set as such.
Q 45 Should be 0 as well.

Hello Tyler,

Thanks for your quick reply.

Q91 = 1
Q43= 1561

All this looks good too.

Can you provide a photo of the module in the panel, where it is installed as well as a photo of the module label?

You can send this to us via private message to keep the imei off the public forum

Sure. Be happy to.

I would recommend trying a firmware upgrade using the update cable before a factory reset.

If this is a new panel that has not been used yet with an account, there may always be a physical issue with its radio module port. Do you have an older 3G module still? It wouldn’t be able to be activated, but you could install it and power up the panel to test whether or not it can read that module.

Hello Jason.

It’s been awhile, but I was finally able to get a firmware update cable and run the firmware update on my panel.

There is no change at all which makes me very sad.

I suppose at this point I have to guess this panel is completely unusable as a monitored panel unless there is something more you can suggest.

Thanks in advance for any kind of suggestions you can provide.

If you have updated the firmware and tried both a 3G and a 4G module and the panel doesn’t recognize them, then based on the previous troubleshooting it sounds like that panel may just have a bad module port unfortunately.

The last thing I would try is a factory reset: