New panel won't power up

I’m in the process of installing a new Qolsys IQ Panel 2+. I connected the power wires directly to the appropriate +/grd spots on the board. I initially got a green led and the panel powered up. So, I proceeded with snapping it into the wall mounting panel and it lost power all of a sudden.

Now, it won’t power up at all. I’ve checked the power supply and it’s fine. I check the wired to make sure they were securely connected. I’ve also tried powering it up via the barrel connector (as opposed to wiring power directly), but that didn’t make a difference (still dead).

Any advice?


There is actually a power button on the side, which is unusual for a security panel. Hold it for a few seconds and hopefully it will boot up.

Sorry, should’ve mentioned that I tried that previously. Still unresponsive.

Darn I was hoping that would be an easy one. When you say you tried it with the barrel connector, was that with the exact wire that came with the power supply? Or did you splice the barrel connected to the wire in the wall?

Usually the problem is either:

  1. The panel is turned off and needs to be started with the power button.
  2. There is too much voltage drop on the wire in the wall.

Also, maybe a silly question, but are you using the transformer that came with the panel when you have it wall mounted? You probably know this but it’s 7VDC not 12VDC.

If we can’t get it working we can always swap it out with a warranty replacement panel.

Yes, I’ve been using the Qolsys transformer from the beginning. Originaly had the transformer connected to my own wiring. When I tried the barrel connector I used the short cord that came in the box and connected directly to the transformer (no splicing).

Well then it doesn’t sound promising. I’ll check with a few other techs for ideas and if we can’t come up with anything we can do the replacement on Monday when the warehouse is open.

One last Hail Mary… this is how you tried booting up?

Yes, that’s the sequence I followed. It started to power up and then just went dark and wouldn’t respond after that.

Sounds like the panel or transformer blew

Ok. Is this a common issue? Should I be leery of Qolsys equipment?

No this isn’t a common issue at all this can happen to any panel no matter the make of it it’s just a defective panel

Ok, thanks. What do I need to do to make a warranty claim (e.g. fill out form, print return label, etc)?

It’s uncommon. Qolsys panels are pretty solid. I still want to check with other techs for ideas on Monday but if they don’t have any then we can do the replacement Monday. Our warehouse isn’t open on weekends so I can’t start it until Monday anyway.

Did you try a different outlet? Same result?

If so, and it still doesn’t boot up, a warranty replacement would indeed by the next step. I will have customer service get the process started for you. They should reach out later today with next steps.

Be sure to keep all of the accessories and box for the return.

It looks like customer service reached out to you with next steps but needs the panels IMEI number for processing the return. Be sure to include that in reply (but do not post it publicly on the forum).

If you have any additional questions, just let us know!