Moving cameras to my new account

I just switched from another provider to surety cam I am trying to get my cameras (model ADC-V520IR) to work with my new account with surety cam with no luck. Any suggestions? They always worked flawlessly with my other provider. I don’t ever remember a disconnect. I can’t imagine what the issue could be. I have rebooted everything and reset the cameras but it’s not working. When I connect my camera to the cable coming from the router, the camera goes through the boot up but will never go to a solid green light, it continuously flashes. Any help would be appreciated. Thank you.

You’re right, that should be simple and straight forward. Two things have to happen before you can do it.

  1. The cameras have to be deleted from your old account. A camera can't be registered with 2 accounts at the same time.
  2. You have to reset each camera to factory default settings so the camera no longer thinks it's on your old account.

It sounds like you’ve already reset them to factory defaults but are you sure they’ve been deleted from your old account?

Here’s a little more info on resetting them to factory defaults.

If for some reason the cameras are still associated with your old account and you no longer have access to delete them yourself then we’ll have to wait for tomorrow morning when is open for business to get help moving them over.

Hello Ryan. Thank you for responding to my earlier post so quickly. I followed your instructions and also rebooted my router. Nothing is still working. Of course I have no way to be certain, but I believe they are hung up in my previous account. Any additional help you could provide would be appreciated. Thank you again.

According to, your cameras were successfully deleted from your old account, so that most likely isn’t the issue.

When you’re booting up the camera, do you have the ethernet cable plugged in before you’re powering up the cameras? I’ve found that when you’re trying to learn in new cameras, it is best to follow this order of operations to get them to connect easily.

1.) Plug the ethernet cable into the router.
2.) Plug the ethernet cable into the camera.
3.) Power up the camera.

The green light should hold solid after about 3-7 minutes. It’s also possible the camera defaulting did not take during your initial attempt. In the past I’ve had perform the default procedure a couple times before the camera was actually defaulted. It’s not something that occurs often or even semi-regularly, but it is something I’ve had to do.

When I deleted/readded my ipcam I didn’t connect it to the ethernet/ad hoc network on computer.

Before powering down, deleted off, then I held in reset on camera itself using a straight pin/safety pin. Then I disconnected power, and then I connected directly to modem/wireless router via Ethernet cable, then I reconnected power.

Ipcam found internet, and went green. Then I added it to, and set up wireless. That was troublesome as certain characters are not allowed, so I had to set up a new WPA2 AES key using only ASCII characters,then set up the connection manually.

The fact it is red/blinking red, means it isn’t connected to LAN/WAN/Internet

Could be IP conflict/DHCP reservation issues, firewall issue, or MAC address filtering issue

I have the same problem with a Vivint-labeled V520IR that I just bought from eBay that came “factory sealed” but I also get the dreaded BGLD (Binking Green Light of Denial). If I load the local agent it properly identifies “ADC-V520IR, port 80” and “New/Not Configured”. But when I try to add I get this error from the page:

Your installation ID is 0000000000

Problem details: Failed to load camera from DB

Yes, I have factory reset this camera a few times now. So can somebody from my dealer (SuretyDIY :wink: - please contact ADC (since apparently I’m not allowed to directly) and find out what this error means. It reads to me like an accounting error on their side or is this some user-unfriendly generic error that could have been reworded more like “we still can’t see your camera over the network”?


I have the vivint branded ADC-V520IR. (Had to have firmware updated to 0100e from 0100m2)

If you are not getting a solid green light that is a problem with your home network (blinking green means limited access/local/LAN only). Period. There is no point even trying to add the camera until you get the solid green light as it will fail.

If you can’t connect your 520IR to, then you are SOL as there is nothing suretycam or ADC can do for you (which includes updating firmware version).


I see from other threads you seem to be the most knowledgeable on the V520IR … but given I dropped my entire network today to connect the camera straight to the modem, even disabled the firewall, and STILL get the BGLS - quite sure it’s not my network.

FYI - The firmware label on the back says “0100k8”. Are you saying I could’ve requested Vivint upgrade the f/w before I left them last week for SuretyCAM? Or how did YOU get the f/w upgrade?

So I’d still like to know from Surety what ADC’s explanation is of this cryptic “Failed to load camera from DB” error. And given it has never been registered does anyone know if there is a default initial Vivint password so I can do any local play with my shrink-wrapped paperweight??

Doesn’t matter what firmware sticker or box says…when you get it connected, the firmware is usually updated.

Vivint updated it to 0100m2 for their new m2m back end, once I reconnected it to ADC, they updated to 0100e so it would work properly.

If firmware is not ADC, camera is no longer compatible and can not be used. Unless box was factory sealed, do not assume it was brand new. Sellers especially on eBay will mess with them or install it, then sell it a month later as “new”

Check firmware on camera settings once you get it online. I requested the manual firmware update once i realized it wasn’t what it was supposed to be.

Assuming it is new, and label on cam says “” and “ADC-V520IR” then, we assume all is good, and deal with obvious issue at hand…

Your camera connection…I don’t know what to tell you. A blinking green light means local/limited connection and no internet. Which means a network issue/connection issue on your end. You need to resolve that first before you even try adding it to ADC.

Backup current router configuration

If using a all in one, and it is in bridge mode, connect Ethernet cable to router port, ditto for standalone modem and router. Do not connect to modem port.

Power cycle router/modem (leave both powered off 5 min)
Factory reset v520ir (till the lights blink), then power cycle camera
Factory reset modem/router
Reset username/password never leave it default
Set firewall to allow all connections or disable it for now
Disable MAC filtering
Try DHCP reserving the camera’s address

Let SSID for network be displayed/visable (hiding SSID is useless, and a waste of time, a free app can easily locate and find networks with hidden SSID’s anyways)
Disable and do not use WPA (manually set it up, unless you want your network hacked)
Check and make sure you are using WPA2-AES and key is alpha-numeric upper/lowercase at least 12 digits long and random

If you do all this, and problem is not resolved. Then completely remove/disconnect router. Remove modem from any bridged mode, and try direct connection to modem ethernet port after 5 min power down/power cycle, and another reset/power cycle of camera.

If still fails, camera may be defective

Ahh, another trick…

I had almost forgot. When I added my V520IR, it kept failing/couldnt find it, so I did it by adding the MAC address off camera manually (I suspect this was because the firmware wasn’t correct as it had already been connected/firmware updated to work with the Vivint M2M back end (as opposed to the ADC back end)

This issue with firmware/ADC EZinstall may become more and more common for Vivint branded cameras as they fully transition away from ADC

FYI, you must also add cams on your local network from a pc/tablet that is also connected to the same network…