Lutron schedule working intermittently

I have a set schedule for my exterior lights connected to 5 Lutron switches that turns them on at sunset and off and sunrise. Lately they have not been turning off consistently in the morning. Sometimes I have to go into the app and manually turn them off. It’s all 5 lights that are staying on, so it seems like a communication issue between ADC and my hub? This also doesn’t seem to be a problem with turning them on at night. What should I be looking at to troubleshoot?

Generally the first thing to try when a timed schedule is failing to activate consistently is delete and recreate the schedule in

Login to your account and navigate to Automation. Click the trash icon to the right of the rule in question to delete it. Wait a couple minutes then recreate a rule with the same desired effect.

Do the lights begin turning off as expected after recreating the rule?

If not do you have any other rules which also affect those lights? If another rule would turn them on and leave them on indefinitely, it may supersede the first.

I’ll give this a shot and monitor it over the next couple of weeks. There are no other rules affecting these lights.

May I ask how you can can set it to turn off at sunrise? I have some Lutron lights set up to turn on at sunset (and they always do) but I have to always manually turn them off at sunrise. However, I use the Lutron app.

However, I use the Lutron app.

I can’t speak to the options in the Lutron app, but in there is an option to schedule an off action in a schedule after turning a device on. Sunrise is a variable for that, or a specific time of day. These are rules and they wouldn’t necessary have the same options in the native Lutron app.

Today the schedule did not turn off the lights at dawn as it is programmed. This is a new schedule I created, per your recommendation. Any ideas?

Can you try power cycling your Lutron Main Repeater? Does this have any effect on performance of the Sunrise rule?

If not, try breaking the rule in ADC into two different rules, one to turn on, one to turn off. Any change?

I have power cycled several times with no apparent change to performance. Before I try breaking up the rule, I discovered something last night that may provide a clue. Triggering my Lutron lights from the ADC app showed an exceptionally long delay in excess of one hour. During that delay, I was able to turn lights on and off immediately from the Lutron app. In fact, my “on at sunset” rule did not launch, nor was I able to turn on those lights from ADC, but I was able to do so with immediate effect in the Lutron app. So it would appear there is a handshake issue between Lutron and ADC here.

Interesting, if that is the case then it may be beneficial to remove and re-link your Lutron account with If the issue isn’t simply an overall slow-down in response from the Lutron API this should help.

Would you like us to go ahead and delete the Lutron integration so that you can try to re-enable?

Ok yes, I am ready. Please also remind me how to enable Lutron integration. Thanks.

Alright, I’ve sent the command to remove that for you. You can find the Lutron Caseta link in the website under Settings > Devices. Scroll to the bottom of the list to find the Lutron Caseta option.

If you have RadioRa instead, please submit your Main Repeater serial number via a private message to Surety and we will add that for you!

So after re-linking Lutron and creating a new automation schedule, the lights again failed to turn off today at dawn. I will try breaking this up into separate on and off schedules.

Thanks for following up. I’ve seen breaking up the on and off schedule to help with rules in the past, hopefully that resolves the issue here.