Linear PS15Z-2

I have a Linear PS15Z-2 on/off switch I’m trying to connect to my system. When I hit add devices on my panel and hit the learn button on the device nothing happens. Do have any suggestions on what I might be doing wrong?

I would first suggest removing the device, (even though you haven’t added it) because the manufacturer will often test these devices before shipment, but never remove them from the test network to which they were assigned. First select “Remove Devices” on your 2Gig panel and press its learn button. Then try adding again. It’s good to do this for any zwave device you try to add.

I’m assuming you have the switch module close enough to the control panel. They say devices should be within 6 feet during the learn process but I find that light switch modules seem to learn in just fine as long as they’re within z-wave radio range of the controller. Usually that’s within about 30 to 50 feet. If your device is within z-wave range then there are 2 problems people run into most often:

  1. With Linear or Evolve lamp/switch modules such as the PS15Z-2 you actually have to hit the learn button 2 times in a row to learn the device, not just once like most z-wave devices.

  2. Z-wave devices can only be included in one z-wave network at a time. Often when the manufacturer is testing the module they forget to remove it from their test network before they box it up and ship it. Your module might think it’s currently enrolled in another z-wave network and therefore will not join your z-wave network. Put the 2GIG panel into “Remove Devices” mode and then double tap the learn button on the switch module. If your device was already in another network then it will be removed. Now you can put the panel in “Add Devices” mode and add it to your z-wave network. If this is the case then you might even see a message on the 2GIG panel telling you a device has been removed from the network.

I bought 5 of these from Surety and 3 worked fine, but two are not working. I did what you said regarding removal and add device, but they still are not showing up like the other 3. Any thoughts?

If it’s not one of those two problems then they must be defective and need to be replaced. Sorry, there’s really not much more we can try. I’ll have an RMA notification sent to your email.

Can you send me to 2 more out or do you need for these two to come back?

We can send you you the replacements but we charge your credit card for them and when we get the returned items we refund it.

Also something to keep in mind with the plug in modules is that when pressing the learn button twice to add them to your system, you must press the button very quickly. In fact, when pairing those devices myself, I’ve noticed I nearly have to beat the relay inside the device (which that face button also controls). I know it may sound like a strange suggestion, but try pressing the button twice as fast as you can when adding or removing.

I tested these returned light switch modules and it turns out Jason’s last post was right on the money. They both worked fine but I had to double tap them pretty quickly to add them to a z-wave network. We’ve seen some variation on these light modules, some of them will work with a slower double tap but others will only work with a quicker double tap. If anyone else has trouble adding Linear or Evolve appliance/lamp/light switch modules to their 2GIG z-wave network, try the following.

  1. Put the 2GIG panel into “remove devices” mode and double tap the light module very quickly.
  2. Put the 2GIG panel into “add devices” mode and double tap the light module very quickly.

Best Regards,