Learning in my Schlage lock

I just tried to learn my Schlage lock into the 2gig panel but I have had no luck. I put the panel in the add device mode then go to the lock (less than 6 feet away) and hit my 6 digit master code then hit the Schlage button and then 0. It blinks trying to pair but never does. I have downloaded the newest version of the firmware for the panel off of your site. Any ideas?

Have you tried removing the lock from the network first? It seems counter-intuitive, but a lot of z-wave devices leave the factory still on test networks and since they can only be on one network at a time, then you can’t add them to yours.

What model lock are you trying to add?

Thanks for the quick response. I have not tried to remove it, how do I do that? Its a Schlage BE369NX.

Its a very similar process to adding. When you’re in the z-wave toolbox instead of clicking to add devices, push “remove devices” and complete the process. Then actually add in.

So even though it doesn’t show up as a lock or anything in the control panel, just go to remove? Im assuming i do the same process on the lock as i do when i try to add it?

Correct. That should remove it from its previous network.

The BE369 will work with the 2GIG panel but will probably not work with Alarm.com. It was officially taken down from their supported hardware page.


I tried to remove the lock from the network and add it back in, but it still is not working. When i try to add or remove the lock from the 2gig panel it says discovering devices but it never finds one. The lock times out after awhile, beeps and stops blinking. This is my first 2gig system and Im just setting up the panel. I have successfully added a z-wave thermostat with no problem and this lock is new. Anything else I can try?

Out of curiosity are you bringing the lock near the panel or vice versa when trying to learn it in? Zwave devices, locks especially, need close proximity to the controler when being paired.

Can you run your panel on battery and bring it next to the lock to try?

I moved the panel within a few inches of the lock and it still did not work.

If removing it and re-adding it doesn’t work then restoring factory settings might be worth a shot. If that doesn’t help then you probably have either a defective lock or a defective 2GIG panel.

I have successfully added a z-wave thermostat with no problem and this lock is new.

Since you’ve successfully added a Z-Wave thermostat to the 2GIG panel, it’s probably a defective lock. The BE369 is an older model Schlage lock that was replaced by the BE469 years ago. It’s even being end-of-life’d by Schlage. Where did you get it new?

@Dave, I would try removing it a few more times. I just installed a Schlage Connect lock and my two snags were 1) forgetting to remove the lock first and 2) not putting the 2GIG in remove/discover mode before the lock. All was fine after doing it in the right order.


I moved into a new home and the locks were already installed, really its the reason I went with 2gig. There was a problem with the original lock when I moved in and Schlage sent me a brand new sealed lock in retail packaging. Im wondering if this matters but as i posted earlier the model number is BE369NX. NX is for the Nexia system, could it be locked to that system only or should it work with any z-wave device? Also you mentioned reseting to factory settings, were you referring to the lock? If so how is that done?


I did try it in the order you suggested but I will try removing it several more times.

I have one other problem as well unrelated to the lock, I think. I have successfully added door and window sensors but I have some sensor that can’t be found when I move the magnet over the side. I thought it was the batteries so I replaced them but they still are not being discovered. But they are discovered if I open them while the 2gig panel is in discovery mode and it alerts a tamper.

What is the model of the sensor that is causing an issue?

Most door/window contacts will need to be set as Loop 2 in programming, which I suspect may be the issue if it does not report open close but reports tamper.

This video may be helpful. Even if you are using a different wireless door sensor model the steps are nearly identical.

Steps for that lock model’s factory reset procedure will be located in the included instructions.

Restoring Factory Settings Restoring the factory settings will: • Restore the original programming code • Restore the pre-programmed user codes If you have an active account at www.mynexia.com, the user codes listed in the web interface for the lock will be restored in the physical lock when lock reconnects with the bridge. The original pre-programmed user codes will also be added to the web interface. Restoring factory settings WILL NOT exclude the lock from the bridge. DO NOT reset your lock unless you are able to locate the original programming code. Customer service cannot retrieve a lost programming code. 1. For FE599, disconnect the batteries. For BE369, disconnect the 9V battery. 2. On the lock keypad, press and release the Schlage button. 3. Reconnect the battery and wait until the Schlage button is no longer lit. 4. Within ten (10) seconds, press and hold the Schlage button until it lights green and the lock beeps.

The sensors are the DW10, I have added several in with no problems but a few are not getting past the learn section. It will not learn the code from the contact with a magnet but it does learn it if i open the case. This section is before the loop option so I don’t think it applies. Could these be defective? I ordered most of my products online from an installer so I don’t know if he just gave me all the broken ones.

Sometimes learning just doesn’t work. Try manually entering the serial number and loop 2. Then save and exit programming and see if the panel responds to the sensor.

Thank you all for your input and suggestions, I finally resolved the issue with adding in the Lock, Batteries… all it needed was new batteries… Next time I will start with that. As for the DW10 sensors I did add some in but again they are only recognized i open them up and the tamper goes off. Im assuming these are busted unless there is some way to reset these? I do see there is some sort of jumper or something on the chip, not sure if that could be helpful to reset or “flash” the DW10?

Learning them in via tampering is fine, so long as they function on loop 2 with the reed switch. Have you tested this? It sounds like you are saying you just can’t get a device inclusion with a magnet.

Just learn them in via tampering and manually change the loop to 2. Then after you exit programming and save changes, test the sensor’s reed switch with the magnet. Does it fail to signal?