Kwikset lock not acknowledging ADC users

I have recently purchased a Kwikset Z-Wave lock. Through, I added all of my users to have full access to the lock, at all times. The lock does not acknowledge any of the users, and when you press the lock button on the lock, it beeps and will not lock since a user code does not exist. I tried adding the codes directly to the lock but after a brief period (maybe amount of time it takes to sync codes from ADC), the codes disappear out of the locks memory as well. The lock is about 13 feet from the panel and is in it’s original position from when it was learned in the panel. I’ve also did network rediscovery, removed and added the lock back to the panel, and verified my ADC settings.

When I manually enter the codes into the lock, for a brief period The lock does work with the codes and notifications from indicate the correct user entering the code. I just think that when it tries to resynchronize the user information, the lock drops all of the codes but it never pulls the set of codes from ADC, thus all codes are gone.

Alarm is a GC2, plenty of cell signal. All of my zwave devices have not been moved and have nice fresh batteries and are communicating properly. Any ideas? I’m at a loss. I’m a IT engineer and amateur radio operator and have a rather extensive background in anything electronic, but this dumb thing is stumping me.

No support? Are the forums broken? Lol

Surety technical support is performed during available business hours, happy to help!

Looking at the account, it appears that all the users are reporting as having been successfully sent to the lock. Is this issue still occurring?

One thing to consider, based on the description it sounds like you are saying the lock was learned in about 13 feet from the panel, in place on the door. Believe it or not, this is too far for a reliable pair process. This is a common “gotcha” with Z-wave. The system can appear to learn the lock successfully, but secure enrollment may have issues.

Always learn locks in within 6 feet of the panel, then move them to their permanent location, or bring the panel to the lock to learn it in.

Also, always allow 5 minutes per code sent to the lock for the codes to be accepted.

Okay, I went through the unnecessary trouble of holding the lock while standing at the panel and I left it in place for an hour while I disallowed and re-enabled user lock access. I also tried to remove and reads users. The lock never learns any codes. As i said, even if i put the codes directly into the lock, the panel causes the lock to forget them within 5 minutes and renders the entire electronic part of the lock useless. I’m still having to use a key… what’s next? It’s got brand new batteries, the panel readd lock status and will lock and unlock it through the zwave menu. It just seems to be isolated to the lock and panel not sharing user codes, and if it does, it erases the codes I’ve put directly into the lock. I guess the panel tries to rewrite the user codes on the lock but it does not actually store my users into the lock. It just removes the codes over and over

Do other customers have to disassemble lock and take it off of their door to remove or add access every time? This makes absolutely no sense to me. Common Sense tells me this is not how it’s supposed to work

Okay, I went through the unnecessary trouble of holding the lock while standing at the panel and I left it in place for an hour while I disallowed and re-enabled user lock access.

That is unnecessary and not suggested. You don’t need to bring the lock within close proximity of the panel to send codes.

You need to bring the lock within close proximity of the panel to learn the lock into the panel initially.

The proximity rule applies to pairing the lock to the panel. If the lock is learned in outside of the recommended distance, pairing can partially fail, the encryption handshake can fail, etc.

It sounds like there is a user code slot discrepancy between the panel and lock, and the first and most important troubleshooting step would be to delete the lock from the panel and re-pair the lock close to the panel.

After pairing, move the lock to its permanent location and run a network rediscovery at the panel.

The lock is not reporting any neighbor status currently either, indicating pathfinding for signals may be off.

If you have already re-learned the lock into the panel within the recommended 6 feet and are experiencing the same issue, you should reboot your alarm panel, then delete the lock from the panel and factory reset the lock using the factory default procedure for that model of lock.

After rebooting the panel and resetting the lock to factory defaults, then try the pairing process one more time.

How many users are you trying to add to the lock? Perhaps start with only a single user, rather than all users? I have a Kwikset Z-wave lock and it has worked perfectly, once the pairing completed successfully, for a number of years now (With GC1 and now Qolsys IQ2+) for what its worth.