Issue Updating Skybell HD

We finally got internet to add the Skybell HD to our account. Got it added and did some adjusting to the wifi to get around an 80-85% signal strength. However the video is practically black and scrambled. I also noticed in the ADC web console that it is on firmware 1072 and there is a new one 1141. I tried updating from the adc web page and it constantly fails. Any suggestions to get this updated?

This is a known issue with original stock models with 1072 firmware. That is the oldest firmware an ADC branded Skybell HD can have. See this post for more info.

If that Skybell was purchased new, it is an old stock device (a few years old)

The only known resolution for the issue with 1072 not updating at this time is to replace the Skybell. Let the vendor know that the device is not usable and cannot be updated via Skybell or ADC servers.

Yeah I read that post earlier and was hoping maybe something changed. I bought the skybell probably 8+ months ago and since we just moved in I can’t find the receipt anywhere. I didn’t anticipate being this far behind from moving in as we had almost a 4 month delay so we’ll see if Skybell support can help me out.

As far as the image issue did you guys see that on that firmware or is that an issue from something else? It really is abismal and I could be standing in front of it and you would never know it. I’m working on faster internet but my upload is about 2mb to 2.5mb which is what they recommend but I wonder if it isn’t enough.

Thanks again guys!

2mb upload is recommended for the cam alone, not in total on the network. You would need to likely reduce resolution to view video. Note that 85% signal quality is not good for the original Skybell models. More recent firmware lessens the wifi requirements somewhat and helps stabilize performance.

Ok that’s good to know. I will keep working on both fronts and try to update on here to help someone else down the road if they have the same issues. Should have some booster equipment coming the middle of this week to help bump my download and upload speeds at home.

On another quick note, the 2gig gobridge. I have it added to my 2gig system, do I just plug it in and it grabs an ip and that’s it for setup?

Once it is installed and enabled properly, should automatically recognize this and utilize Dual-Path communication. More information can be found here.

It appears that your panel is communicating via dual path currently.

So this is the response I’m getting from Skybell.

“The only thing we recommend to is power cycle your Wifi network and the Skybell to reboot the entire system. After re-try the connection process again. I cannot offer any other advice or insight as support should be through”

I get the feeling they don’t even make an effort to support their product. I’d love to take it back to the vendor but I can’t find the receipt and it’s been at least 8 months since purchase due to delays. Am I up a creek? Just for clarification I didn’t buy this unit used and it was brand new when purchased but apparently was old stock which I didn’t know at the time. I have a real hard time with the fact they are manufacturing these, writing the code for them (even though it has specific adc apis), and then when they have a bunch that don’t update they just throw it on the vendors to deal with.

Thanks again for your help guys.

A Skybell HD (round version) ADC branded or not, can be used with the ADC app or with the Skybell native app. They use the same firmware either way.

During the pairing process and setup on either ADC or Skybell, the firmware will be updated to the latest available. In the case of this old 1072 version, it can fail to accept the update commands. Manually attempting to update later also fails.

It is not a great situation, I agree. I cannot speak for the manufacturer, but considering all units with 1072 firmware are old stock and out of manufacturer’s warranty period now they may be a lower priority. We will prod ADC to see if they have gotten any different feedback from Skybell or if a fix is in the works. As of the last available info, a new unit would simply be needed.

We will update here when we get word back!

Maybe you guys will get as much of a chuckle out of this response as I did. Skybell support is worthless.

“Understand hat this not refusal to help you from our end. What you purchased is an product that is listed as the Skybell edition. This product is and should be fully supported by We have never heard of their statement “The only known resolution for the issue with firmware 1072 not updating at this time is to replace the Skybell.” so you may want to speak with someone else in regards to updating the device or ultimately having it replaced. Again, understand that we do not offer support for the version and any troubleshooting/complaints should be done with support directly.”

What you purchased is an product that is listed as the Skybell edition.

This is true if it is the Slim Line. The Slim Line ADC Skybell is only compatible with ADC.

The statement is backwards for the HD (round model) as it is jut a branded Skybell HD.

Just wanted to update real quick. I added a second internet line to get me up to about 3-4mbps upload combined through my untangle firewall/router. After doing that I now get picture/video from my device.

Skybell has ceased communications with me on the ticket so if ADC has any insight or help that would be awesome. I’d even be willing to send the unit somewhere to get it upgraded if possible. Thanks again! indicates that a this is an active issue and that they are working on a fix but there is not an ETA for a resolution at this time.


We recently went through this same issue with a 1072 firmware version’d SkyBell back 4 months ago… In the end we ultimately had to replace the SkyBell with a new unit with a more current Firmware from the manufacturer. One of the many SkyBell 1072 issues is the inability to upgrade the firmware. Thus resulting in a faulty unit that can’t be updated remotely.

I don’t have my entire troubleshooting experience in the forum but you can see what is here in the following link. It contains some conversations I had with Surety, ADC, and SkyBell.

We were lucky and our local vendor was more than happy to assist and help us troubleshoot beyond what ADC and SkyBell were able to do. Like I said ultimately our vendor swapped units with one that was newer and all issues were resolved. We have purchased multiple pieces of security equipment from them so I leveraged the “Good Customer” and they had no problem working with me.

I might suggest you revisit your vendor and explain the entire problem and see if they will swap out your unit. Being as they are a vendor maybe they will be able to conduct an Return to the manufacturer on their end to resolve the “Old Firmware Issue”. They shouldn’t have sold you an inferior unit with old firmware in the first place in my opinion.

FYI - The firmware is printed on the box. My local vendor actually connected the new SkyBell to their demonstration account and conducted a firmware update and verified everything worked before giving the new unit to me.

NOTE - If your vendor does this make sure the SkyBell is completely removed from their account prior to leaving their office. A SkyBell can only be connected to one account at a time and if they don’t get it removed will not allow you to pair it when you get home. Requiring another phone call.

Good Luck !! My wife loves our SkyBell I hope you get it (or a new one) working.