IQPanel Remote - Patch Verification failed

The panels are now connected to the IQ panel access point, but its the same result of patch verification failed. I connected the remotes by IP to main panel when doing a reconnect and it finds panel to start patch download again. Gets to 100% and then shows same error.

1 Like

You mentioned rebooting, was that the Remotes or the IQ Panel itself? I would reboot the IQ Panel, reboot the router, then once the IQ Remotes reconnect try again.

What firmware version are the IQ Remotes on right now? What version did you upgrade from?

My reboots have been on the remotes. I have rebooted the Panel recently and no change.

I went from 2.5.3 I believe to 2…7.0. The remotes had no issue going to 2.5.3, but when i went to 2.7.0 on the main panel, the issues started. How can i tell the version on the remotes?

The remotes show 2.5.2rc2

The remotes show 2.5.2rc2

That is the issue I think. That strikes me as a non-production firmware version identifier. Looks like those got incorrect firmware through the panel. Let me reach out to Qolsys and have them confirm and see what steps to resolve.

1 Like

Still waiting on follow up from Qolsys. At this point we will not hear back from them until after the holiday. We will follow up as soon as we have more information.

1 Like

Have you heard anything back yet?

Not yet, I have reached out to them to see if we cant get some more information today.

1 Like

My reboots have been on the remotes. I have rebooted the Panel recently and no change.

Have you performed a Master Reset of the IQ Remote? If not, to do so, click on the 3 vertical dots in the upper right hand corner of the IQ Remote main screen and select Master Reset. This will factory default the IQ Remote, and you can retry connection.

1 Like


I have tried this and it does the same thing trying to pull an update. I’ve connected the remotes to my SSID and the IQPanel AP. They pair, sync with panel, download the patch, and fail at verification. It’s the same error message.

Thank you for that information. Im working with Qolsys to get this resolved, what are the Serial Numbers for the two remotes affected?

These numbers can be found on the back of the unit and begin with QWXXXXXXX

I’m having the same issue on my IQRemote panel in our bedroom. I’ve rebooted, reconnected, rediscovered, tested, master reset, rebooted both panels, verified connection on the same network (they see each other and talk to each other successfully).

It breaks at the point when it’s downloading the update, then “patch verification failed”. I can’t get out of the main wifi/configuration screen. It’s non-functional.

It would have been handy last night during our Tornado Warning in Kansas City, which is why I’m posting for support. I need to find a solution quickly, I’ve let it sit unfunctional for too long.

What is the firmware version the remote currently shows?

The current firmware on the remote shows as 2.5.4rc19. I just upgraded the panel to 2.7.0rc to see if it would fix it, but it did not. Same behavior, downloads the patch immediately after establishing connection with the main panel, then the message patch verification failed.

Forgot to mention, I totally deleted the remote panels and re-added them to the main panel, still same issue.

I downloaded the 2.7.0rc firmware to an SD card, but it looks like there is no SD card slot on the IQRemote panel to do a manual upgrade from the card. A bit stuck at this point.

I remember an issue a while back that required increasing log level.

I haven’t tried this yet, but I would only be able to modify on the main panel. The remote panel doesn’t have access to the settings, it’s stuck on the wifi and test/reconnect screen.

[Removed by Admin}

To clarify, you updated the main panel to firmware version 2.7.0 already? Can you confirm by navigating to Settings > Advanced Settings > About > Software > Software Version

Thank you for that information, I will follow up shortly.

1 Like

I was finally able to get this working today. I tried to upgrade the main panel to 2.7.0 over network and it didn’t error out, it just rebooted back to prior version. Then I tried the SD card method. Same thing. Tried again. Same thing. Changed log level to verbose (was debug), and tried again from SD card, it finally upgraded to 2.7.0! Shortly after the remote fixed itself. All is working now.

I’ve seen the IQPanel be extremely inconsistent in applying updates in the past, and this was no exception.

The user interface on the 2GIG CG2 is nicer, the z-wave was more consistent, upgrades were more consistent, overall a more seamless experience. I may go back to 2GIG if I ever upgrade. Been really frustrated with Qolsys lately.

The user interface on the 2GIG CG2 is nicer, the z-wave was more consistent, upgrades were more consistent, overall a more seamless experience.

Thank you for your follow up and confirmation regarding the log level. I understand frustration with a firmware update snag like this. It’s a really annoying issue to try and troubleshoot.

The interface notwithstanding, as that is user preference of course, I want to address the other points based on my experience as an installer and support rep.

On the whole, 2GIG GC2s had serious problems with firmware application. OTAs take hours, the update cable application was archaic even when it first came out. The panel update process is comparatively fragile, and issues often result in an irretrievably bricked panel rather than a bug.

As a direct comparison to the IQ Remote update problem in this thread, some GC2 firmware versions had significant issues where the GC2 would no longer process any 900Mhz device signals, causing all secondary panels to fail, requiring replacement of the main GC2 panel.

GC2 Z-wave was also (to me) less reliable overall. GC2s have issues where a power loss can delete the entire Z-wave device list. Rules failures were more frequent in my experience with GC2, especially sunset sunrise rules, though that may be influenced by ADC making improvements over time.

That said the GC2 is a good panel, working solidly for a long time for a lot of users, and we recommended it for a long time. I don’t think it compares favorably to the IQ Panel 2 or 4, but the GC2 is much older so a lot of that comes down to feature availability and hardware improvements.

This is definitely feedback I am happy to forward to Qolsys. Always good to identify frustrations to hopefully address and resolve.