Iqpanel 2.7.1 - now countdown/beeps for remote arm

We use remote arm through the app (and scenes) to work around that the Qolsys panel always counts down for arm-stay (our 2Gig did not), and it is quite disruptive to people sleeping in the house when the last person to bed arms the alarm to have the panel and remote panels all beeping for the countdown.

This is a change in 2.7.1, there were no “new features” in the release notes…so what caused this? How can this be reverted? Is there some preference I can set to just disable the countdown beeps for “arm stay”?

This wouldn’t be due to 2.7.1. There is a cause for this however, specifically if you enable Alarm.com scene controls on the panel then any time you arm from any source the panel will always follow the exit delay.

To stop this and arm immediately with remote commands, disable scene control on the panel.

  1. Go to the home screen.
  2. Tap Settings .
  3. Tap Advanced Settings .
  4. Enter the installer code.
  5. Tap Installation .
  6. Tap Installer Settings .
  7. Tap to disable Scenes Support .

to work around that the Qolsys panel always counts down for arm-stay

There is also a setting to adjust this so you can arm stay at the panel without an exit delay. Enable Arm Stay - No Delay. This is found in the security and arming menu.

  1. Go to the home screen.
  2. Tap Settings .
  3. Tap Advanced Settings .
  4. Enter the installer code.
  5. Tap Installation .
  6. Tap Security and Arming.
  7. Tap to enable Arm Stay - No Delay

To be clear, before upgrading to 2.7.1, having changed nothing else on my part, when arming via the app (either via Arm Stay or a Scene that included Arm Stay) the panel would simply announced “Remote Armed Stay”. Now it instead goes into the full countdown sequence.

The behavior was the same if the actions as performed from a mobile device or within the Scenes Support on the panel itself. The 2.7.1 software completely changed the behavior.

This is at odds with the documentation and may have been a stealth change at some point. The expected behavior documented in Alarm.com, is that if you enable Scenes support on the panel that the exit delay will be triggered on all remote arming commands, through scenes or just through the app, on both Stay and Away arming.

Testing on a 2.6.1 panel it looks like in the event of arming Stay, the exit delay is not triggered. On Away it is.

So, on 2.7.1, the behavior is indeed matching the expected documentation.

This was all to try to get back to the way my 2Gig panel worked, that “arm stay” didn’t result in an audible countdown. It still performed a countdown, but it was silent…but still provided audible countdown for doors/windows before alarm would be triggered.

The key goal is to be able to “arm stay” without waking up the entire household with a long beep-beep-beep-5-4-3-2-1.

When arming from the mobile app, is the “Silent Arming” option visible? You should be able to use this feature to arm remotely without the beeping or announcement.

This work around did help, thanks. It is strange that the behavior changed with the firmware update of the panel, but the work around is fine.