IQ2 WiFi Issues with Back End Communications

I received an email from asking me to enable WiFi on my panel. The panel is attached to my home WiFi network. It passes the WiFi speed test on the panel, and I can access my door bell camera video from the panel. When I run the cellular test it receives receipt from the back end. However, when I run the dual path test, it says WiFi communications test started, but no receipt from the back end, and attempts to retry, and then fails with a time out. Any suggestions to resolve this?

Your panel can connect to the wifi LAN but cannot receive communication across the internet. Looks like this broadband failure has been a trouble condition for a while. Commands can only reach the panel via cell.

The first step would be a reboot of the panel and the wifi router. Any change?

If not, what model of router do you use?

You should also update the firmware of your panel, it is currently using an older version. Steps to do so can be found below. Any change after the firmware update?

Successfully updated to 2.7.1. Still failing dual path test:

  • WiFi communications test started. Please wait.
  • Waiting for CS response. Please wait.
  • WiFi communication test timed out. Please try again later.

No changes with router rebooting. Using Asus RT-AC86U running latest firmware. Also tried with disabling the router firewall… no change.

I also paired the panel with my cell phone WiFi hotspot, and re-ran the test – bypassing the router, with the same results.

Alright, I’ve tried resetting the dual path connection but it did not have an effect.

I am able to send a ping via cell and request a response by broadband, the panel reaches ADC that way through your broadband, but inbound broadband messages do not reach the panel.

This specific behavior has been seen once before, and unfortunately per the prior case the only solution which resolved that error was a panel factory reset. See the thread below:

I am now having this exact same error as well. I noticed I was running 2.5.2 and upgraded to 2.7.1 which did not fix the issue. Note I had to do the upgrade manually. I have rebooted the router, rebooted the Qolsys 2+ panel, disabled dual path, disabled wifi, forgot network, re-enabled, reconnected and even tried to route through a different wifi network. Nothing worked and still have the same error as Michael stated above.

Running a few tests on your system I can confirm it looks like the same behavior.

Your panel can communicate out to via broadband, but it is not replying to inbound broadband pings.

2.5 firmware versions have been common to the few instances of this I believe, but updating that firmware has not resolved it.

The original troubleshooting and the factory reset solution are described here:

Thank you. I did a factory reset over the weekend, rebuilt the system and everything is now working as it should. Thank you for the help. FWIW - Qolsys really needs some way to backup all the devices and ability to do a restore which would save a ton of time in these situations.

I think my panel is having the same issue. Wifi test ok, cellular test ok, Dual Path it says Wi-Fi communication test started. Please wait…
Waiting for CS response. Please wait…
Wi-Fi communication test timed out. Please try again later.

Can you please confirm if I am having the same issues?

I do see the same basic behavior. Can you confirm when this issue began?

You might want to try rebooting the router and disabling any custom firewall settings first as the router can be a cause for similar issues.

Jason - any update on this outside of factory reset, which I don’t want to do as it will cost me a half of a day setting the system back up.


No update, only confirmed resolution is reset.

There is a firmware upgrade past what is mentioned in this thread. 2.7.2 would be recommended as a test:

2.7.2 did not fix it. :frowning: