IQ2 Upgrade problems

I’ve been having multiple issues since upgrading the IQ panel to 1.5.1. After having to relearn all my sensors and z wave devices, the last thing that I can’t seem to get completely functioning again is the IQ2 panel. I’m aware of the 1.5 update for the IQ2 which will hopefully address my issues though I’m unable to get the IQ2 to download the update from the IQ panel. I have downloaded the 1.5 update to the IQ panel using patch tag iq215 but when I push the update button on the IQ2 it shows"control file not found". The IQ2 shows as connected to primary with the correct MAC address and IP. I am currently able to arm my system from the IQ2 panel but attempting to use any other function shows the error message “primary not found” so it seems as though the IQ 2 is only partially communicating with the primary panel. I’ve tried resetting the IQ and IQ2 multiple times along with adding and readding the IQ2. I’ve also changed the IP addresses of the devices without any success. The devices are all connected to the same network and were working fine prior to the 1.5.1 update. Currently I’m running the 1.5.1 firmware on the panel and 1.4 on the IQ2. Any help would be greatly appreciated since I’m pretty much out of ideas at this point.

To verify, have you been following the steps in the attached image? Double check and make sure a step has not been missed.

I have downloaded the 1.5 update to the IQ panel using patch tag iq215 but when I push the update button on the IQ2

You should be using the “Update IQ2 using Network” on the IQ panel itself. It sounds like this may not have been tried yet?

I had the exact same problem! You need to run a quick test: Let your IQ2 panel go dark. Then, tap the screen and see if it wakes up. If it does not, you have an older version that requires replacement as it is a hardware problem. I spent hours on this yesterday and that was the final conclusion. If the panel is under warranty, they will replace it with a new version. If not, you are SOL

I have used the “Upgrade panel using network” command with no success. I’m starting to lean towards the old panel since I purchased the IQ2 right after they came out. Did you go directly through Qolsys for the warranty replacement?

Okay just did the test that you recommended. Display timed out and nothing happened when I touched the screen. Only way to get the panel back on was to push the side power button. I purchased the IQ2 from Suretydiy on May 4 2015 so I’m hoping that it should still be under warranty. Would someone be able to advise on who to get into contact with regarding the warranty? As always thank you for all the help.

Our Returns and Warranty Policy can be found here. However, since this is a special circumstance it appears, allow us to contact Qolsys when they open (West Coast) and verify any special instructions.

Sounds good. Thanks for your help

If your IQ2 screen does not power on by touch and you cannot upgrade to 1.5, please send an email to with your appropriate shipping address information and the original suretyDIY order number of the IQ2. We will then facilitate any special replacement.

Sent an email. Thanks for your help.

Did you call Qolsys to replace it? I didn’t buy the IQ2 from Surety.

Since I purchased mine from Suretydiy, they have been great in facilitating the return to Qolsys for me so I had not contacted Qolsys directly. Sorry that I couldn’t be of more help

Did you call Qolsys to replace it? I didn’t buy the IQ2 from Surety.

warranty returns are most likely through dealer only. I doubt Qolsys will deal directly with end users. You should contact the entity you purchased it from. Otherwise, you may be SOL on any warranty claims.

I buy alarm sensors and equipment online from non-dealers all the time, but I do so knowing the risk that that the manufacturer warranty is most likely voided. Your best bet may be to contact Qolsys yourself (if the seller is of no help).

Keep in mind this only applies to units manufactured up to May 2015. Units that wake on touch are not affected.