IQ2 Unable to connect to primary

New Qolsys panel today. Things went well with it. Tried adding the first IQ2 tonight and keep getting meesage “unable to connect to primary”. I have deleted and reinstalled and got same message. I have checked wifi…excellent signal. The message on the IQ panel states it is connected. Any suggestions? Thank you.

Software on IQ panel is 1.5.1.

What version is on the IQ2?


Both panels purchased from suretydiy.

Qolsys released a new version of the 1.5.1 update very recently to address some connection issues between the IQ and IQ2. Can you go to Settings - Installation - Upgrade Software - Upgrade Using Network? See if a new patch downloads for 1.5.1.

The IQ2 will need to be updated to 1.5 for full functionality as well once connected to network.

Steps below for updating if your panel is already 1.5.1:

  1. From the IQ Panel touch “Settings”
  2. Enter a valid installer code (default is 1111)
  3. Touch “Installation”
  4. Touch “Upgrade Software”
  5. Touch “Patch Tag” and enter the patch “iq215” then touch Done, then OK
  6. Touch “IQ2 Panel Upgrade Using Network” and the update will download
  7. Press OK when prompted to send the update over the WI-FI network to any IQ2’s that are paired
    with the panel.
  8. Follow the on screen prompts on the IQ2 to accept and install the 1.5 update. Once installed the IQ2 will relaunch the software. Verify that it has been successfully updated by going to
    More>About. The Software Version should read: IQ2 – 1.5

Some things to try with the IQ2 to get it synced with the panel:

  1. IQ2 Settings — Resync. This will resync with the main panel.
    if nothing changes
  2. Master Reset IQ2 in IQ2 settings. Remove from main panel and add back.
    if nothing changes
  3. Do step 3 again. Forget network on IQ2. Log into router and remove any IQ2’s on Offline device list. Reconnect IQ2 to network and pair again to main panel.

So I downloaded the upgrade, entered the patch tag and it seemed to bring the iq2 to life. However, still getting the small red error message down at the bottom “unable to connect to primary”. I am unable to try the other things on the IQ2 because it’s not accepting any pass codes. It tells me invalid user each time. The same codes work fine on the IQ panel.

Thanks for the instructions. I finally got the first IQ2 working. Tried to add a second IQ2 today and all I get is the error when parsing the package error.

In trying to get the second IQ2 working with the panel, the first IQ2 has reverted back to “unable to connect to panel” errors. One IQ2 panel shows version 1.5. The other IQ2 panel shows version 1.4rc1. I have also switched to a different router with no success. Both IQ2’s continue to say “active” on the IQ panel.

Have you performed the “Master Reset” function on the second IQ2?


Is the master reset different than the reset that is shown on the more menu?

No. Let us check with Qolsys on this. As long as you have reset/removed the device from the router device list and removed from the IQ, you should be able to reconnect. We will follow up with further suggestions.

What model of router have you tried?

Used Apple AirPort Extreme first. Currently using Linksys WRT1900ACS.

Believe I have the issue. Thank you for specifying the firmware. Did you purchase the IQ2 with 1.4rc1 through suretyDIY or another vendor? This is actually not a production firmware version and is likely a mistake from manufacturing. This version won’t be able to be upgraded.

If it was purchased through us, send an email to and we will get it taken care of. If it was purchased elsewhere, make sure to contact the vendor to get it replaced.

Purchased from suretydiy.

Still having trouble with IQ2 (the one that I was able to upgrade to v. 1.5). I cannot get it to connect to primary. I have pinged it from the IQ panel, rebooted both the IQ and it IQ2, removed the IQ2 and readded it, updated the IQ software. Basically I have followed the instructions you offered earlier numerous times without success.

Can you verify the SSID of the wifi network you have your IQ and IQ2 connected to?

If you have a dual band 2.4 and 5ghz network router, the IQ and IQ2 can connect to different networks, which can hinder this communication.

Both are connected through the 2.4ghz band. I saw another post concerning interference with 5ghz band and have it disabled on my router.