IQ Panel 4 not connecting to Smartthings hub as a secondary Z-wave controller

Just a follow-up to see if there are any updates? Could it be that my unit is actually also suffering from the Z-Wave issues others are having?

no new information from Qolsys at this time. Is the Z-Wave card test failling on the IQ Panel 4? Can you tie a Z-Wave device directly to it (not the ST hub)?

The Z-wave module did pass the initial test when I first set it up. I did test trying to pair a device directly to the IQ Panel as a test and the first few times the device adoption failed. I rebooted the IQ Panel and it did successfully adopt the Z-wave device.
I removed the device and do not have any devices connected directly to the IQ Panel currently. I have done several z-wave resets, device deletes, etc.

I just got my IQ Panel 4 setup yesterday and can confirm this behavior seems to be what I am seeing as well, sadly. Z-wave module tests fine, but attempting to do add/remove controller functionality pops up the DSK key on the IQ Panel and never connects with SmartThings to initiate the S2 DSK prompt that should happen. The app then errors out with code 34-302 after a while.

Hopefully Qolsys can give some info on getting it to work, and whether this will be supported eventually (or implement the QR code part of S2 which I think is required along with raw DSK).

I ended up doing a crazy workaround to get panel status fed into SmartThings in another way, but it’d be great if they do eventually support this.

How did you end up getting panel status fed to Smartthings? I am missing some automations waiting on suretyhome and quolsys to provide a solution.

First, I created two virtual switches in SmartThings named Armed Stay and Armed Away. I used those for triggering any routines once they change state.

Then I created 3 notifications from for each state (disarm, arm away, arm stay) and had them send an email to zapier with the private email name for each in the trigger (e.g. armedstay.{PRIV_EMAIL_CODE}

Sadly, zapier itself doesn’t link with SmartThings. So, in the action you can either do one of two things:

  1. Create an IFTTT rule that listens to from your email to match the notification and have it trigger the virtual switch it relates to based off of a tag in the subject/body, and have zapier send the trigger email as the action from your email account that you registered with IFTTT.

  2. Go through the process of generating Access Tokens and use the graph.api endpoints for device control

I already had the IFTTT rules from a long time ago so I went the lazier route and used those.

I just wanted to check back on this and see if there is a solution from Qolsys yet?

There is no new information at this time. I have followed up to see if I can get any new information but I am waiting on a reply.

I suspect support would come by way of a future firmware update but I cannot say for certain.

It has been another couple of months and I wanted to follow up and see if you have any answers from Qolsys yet?

No new information at this time, still unsupported.

@rob55d your first post mentions a QR code. A QR code packages the DSK, so since you have a DSK option, converting the QR to DSK may help?
See Silicon Labs Community

I am adding a Simon XT as secondary to a Z-stick gen 7. This setup needs the DSK for the communicator (in the Simon xt). Am not sure where to look…

Sorry I missed your post. I keep an eye out to see if there are any updates that will fix this problem but I guess I am the only one who wants to use the IQ Panel 4 as a secondary controller. I am currently using an alarm .com integration with HomeAssistant to pass the messages but is isn’t perfect.

I have the DSK, I do not have a QR code which is what the panel is looking for to initiate the secure connection. I tried creating QR codes using the DSK but didn’t have any luck. I am guessing the QR code includes device information, protocols, etc…

I somewhat regret my transition over to the IQ Panel family, especially for home automation / security. If I was interested in security only I would say it is adequate for a home setup. The lack of support for setting it up as a secondary zwave controller really eliminates it for any kind of basic + home automation.

I keep an eye out to see if there are any updates that will fix this problem

Nothing specific has been listed in recent firmware updates. Patch notes can be found here for the IQ Panel 4.

but I guess I am the only one who wants to use the IQ Panel 4 as a secondary controller.

You arent the only user who is interested in this pairing and we have passed this information to Qolsys in the past.

Thanks for the update, sorry the conversion didn’t help. Nothing new here, still haven’t found a DSK from my Simon xt to enable security with the Aotec Gen7.

rob55d, I too have a new IQ Panel 4 that I am about to install and planned on making it a secondary controller to my Homeseer ZNet primary controller so I’m bracing my self for failure and frustration. I’ve been using Z-Wave for ten+ years so I’m used to it!:slightly_smiling_face:
I realize this probably will not help your situation but at least it will be another data point (or I’ll get to join you in the call for Qolsys to update their firmware!)

Looking forward to hearing your results. I have not tried it again recently since there hasn’t been another update on my panel.
Maye it is my panel since and I just haven’t heard of anyone else having success. I do not use the IQ Panel 4 z-wave controller for anything else except hopefully as a secondary controller to bridge to my HomeAssistant controller someday.

rob55d, my attempt to add my new IQ Panel 4 as a secondary z-wave controller to my Homeseer ZNet interface failed. I moved my ZNet right next to my IQ Panel 4, commanded my Homeseer to “send controller information to secondary controller” then went to my IQ Panel 4 under “Add Z-Wave/Add/Remove Controller” and pressed it. My Homeseer ZNet saw the IQ Panel 4 Z-Wave Controller was ready to receive information because it wrote to the log “sending z-wave network information”. Then about five seconds later the IQ Panel 4 pops up a message instructing me to “send the following pin code to the other controller…” Well, Homeseer has no provision to input or send a pin code, it’s just sitting there saying “here, take it!” so nothing happened and eventually both sides timed out and reported the failure.
Qolsys needs to rethink their implementation of this command I think. I’ve never seen the pin code requirement before. Also, I was almost happy there was no way to input the pin code on the Homeseer side sense the IQ Panel 4 gave me a forty digit pin code!!! :crazy_face:
(I didn’t actually count the number of digits, but it didn’t fit on one line!!!)

I might give it another try this weekend. I have to move my HomeAssistant server closer to the IQ Panel which usually entails dragging out an extra long ethernet cable just for this set up. I did see the panel try and connect once but it also timed out then never saw the panel again.

I created a support request ticket asking for a “work around” to the 40 digit PIN code Qolsys wants. If it wasn’t for that perhaps my attempt could have been successful!! (BTW, I used a 50 foot Ethernet patch cable to get my ZNet next to my alarm panel! :rofl:)

We received your ticket in and forwarded the details to Qolsys for review. They should be able to help describe what is possible.

The “40 Digit Code” is the S2 DSK (device specific key). This is needed for S2 inclusion, which may or may not be supported on your current controller.

In general it isn’t an officially supported process on any specific controller.