iOS 13 geo-services error?

Me: gets new phone, sets up all the usual stuff. Unable to turn on geo-services on the new phone. When attempting to do so from the app, the permissions pop-up appears telling me it will use locations services and reports back to ADC. Push “enable” and the app crashes. Every time. Log in, log out, log in all the same.

The new device shows up on the ADC website but is greyed out in the geo-services devices section.

iOS 13 running on iPhone 11 pro max, out of the box yesterday.

Any reported bugs or issues with the ADC app no that platform yet?

I’m not aware of any at this time, but we will forward this on to investigate.

Have you tried deleting and re-installing the app?

Also, are you able to enable location settings for the app through your phone menu prior to trying to enable Geoservices? That may get around the error if it is being caused when trying to change permissions from within the app.

Location settings are already set as “always allowed” for the app in ios. But if I reply in the affirmative to the popup in the application, it crashes and dumps me out to the home screen.

I haven’t tried an uninstall/reinstall yet. I’ll give that a whirl. Obviously it was restored from a backup of the outgoing phone so that’s worth a try. I’ll report back.

So uninstall/reinstall appears to have worked. I was holding off on doing that because that just meant I needed to redo all of the notifications and automation that was working with the new phone; it was just geo-services but there you have it. All seems good now.

Thanks as always Jason.

Thanks for following up, glad to hear it was resolved for you!

1 Like