How do I sync ADC app and iq4 panel?

I added a z-wave device, an aotec smart switch 7, and it was added by panel as a light type device.

Question one: isn’t there an outlet type? I can’t seem to edit, on setup or after, this device type.

Question two: I can control this “light” from the panel, But when I check the ADC app, the lights category is empty, and the device doesn’t show up in any other category.

I was hoping to be able to control that switch from the app, from Google assistant, etc. Can I?

Do I need to force sync between the panel and the app?

And when I try “hey Google, turn on TV power” Google voice says the device is not available.

And when I try “hey Google, ask to turn on the tv power” ADC voice says “I couldn’t find any lights on your account”

Make sure you are always clearing then pairing each Z-Wave device. Then after learning in all devices, and everything is back in their installation locations, run a Z-Wave network rediscovery. This should help sync Z-Wave devices with

I added a z-wave device, an aotec smart switch 7, and it was added by panel as a light type device.

However, we have been seeing issues with the Smart Switch 7s and the IQ Panel 4, while they are both 700 series, they may not work as desired. Refer to this list here for Z-Wave devices that have been tested compatible by the manufacturer.

Currently, there are not any lights reporting to ADC, only Locks. I have sent some commands to resync connected devices, missing devices should show up in the next 5 minutes or so, however, the 7 switches may not work correctly.

Try Clearing the switch 7, re-adding, then running a z-wave network rediscovery. Any change?

Z-Wave pairing and network setup instructions can be found below

Here are some screen shots showing that the smart switch seven is recognized by the panel as a light. And had been learned in. And can be controlled as a light from the panel. But is not seen by even though it’s seen by the panel. And is not understood to exist when using voice control.

I don’t know what you mean by clearing then pairing each z-wave device. How can I clear it if I haven’t paired it? Or maybe I don’t understand what clearing is. Anyway, I’m not currently doing it, whatever it is. I’m pairing a new device, then moving it to it’s final location, then rediscovering all the devices.

As far as the list of compatible devices goes, I read in several places that it is not definitive/complete. Also, the six version of the switch is not available, so I have to use sevens.

And then after I ran a registry again, just now, I get a topology that doesn’t use the smart switch as a repeater.

Which is strange, because it’s kind of sight to the panel, while the extender is in the basement near the lock. Yet the signal strength for the switch and the extender are nearly the same. But the extender is slightly weaker, yet still selected.

I guess you might be right that the switch sevens have bugs. But then, aotec says their extender and switch products are both built on identical seven software stack, so go figure…

Sorry, “registry” = “rediscovery”

I never could figure out how to make “clear” work. So next I tried resetting the smart switch seven device itself, then used “delete failed device” at the panel, then added the device in, not at the panel, but through web dashboard.

First, I tried adding it as a smart switch six. This worked, and I could send commands to it from ADC app and web, and also assistant voice integration.

But, the device showed up not as a simple switch, but as a two part device, one part switch and one part dimmer. Even though neither the smart switch six nor the smart switch seven have dimmer functionality.

And, when triggering on/off from the panel, or the app, or the site, or by voice, the switch’s LED would go on and off, but the relay works not switch.

So I reset the switch again, and deleted it at the panel again, and waited for ADC to catch up to the changes, then added the switch back in, this time as a generic device. And again it worked, from all pathways, but also again, commands affect only the switches led, not the relay.

So in summary:

  1. if I add it at the panel, it is correctly registered as a switch, but categorized as a light, and never showed in ADC, but can be returned in and off at the panel, but not by voice or by app.

  2. If I add it through ADC, it can be registered and seem my ADC, addressed by voice and by app and by web dash, but it is improperly registered as a two function device, and it doesn’t switch.

The Aeotec Switch 7 was tried by another user recently, and the issue there is it is not compatible with

It registers as a dual function device, which are not supported by ADC at this time. See my response here for a description.

Thank you Jason, I saw that when doing research on this, and commented there too.

I’m worried that the iq4 is too junky for me to depend on for general z-wave automation.

Are there other panels that have better z-wave compatibility?

The Qolsys IQ Panel 4 is in fact the only panel I am aware of that correctly pairs a multi-function device, splitting its functions into sub-nodes.

The problem you are seeing is because those multifunction devices are not supported by other panels, and does not support them yet.

I think the issue that I and the op were struggling with is that the devices we were trying to attach are not advertised as multi function devices.

The aeotec docs don’t suggest smart switch seven does anything other than turn on and off. We are just trying to get a simple modular switched outlet working.

On the face of it, it appears that the device is being registered incorrectly. There may be multifunction devices out there, but is this one of them? What are it’s two functions?

And I also dispute the idea that the iq4 panel correctly pairs multi function devices.

I think we might agree that it detects a device that is multi function and pairs it, but it definitely does not assign it’s sub functions correctly.

Try it out. A dimmer/analog function is assigned, which does nothing. And the on/off function also does nothing when the device is registered as multifunction.

Only when the device is recognized as a single function device, does it work. There may technically be a secondary function. The op discovered that the led rim of the button can be turned on and off. But who cares? All we want an outlet switch to do is switch an outlet.

Only when the device is recognized as a single function device, does it work. There may technically be a secondary function. The op discovered that the led rim of the button can be turned on and off. But who cares? All we want an outlet switch to do is switch an outlet.

I totally get this and understand. The IQ Panel is not creating a random secondary node. The device is reporting this way.

The Aeotec 7 appears to be sharing its LED as a second function. It is not compatible with the system, unfortunately, at this time. I wouldn’t be able to provide steps to make it work the way you want.

We’ll send feedback that users wish to use the Aeotec 7 with their panels to Qolsys. They may be able to address compatibility with firmware.

For officially supported hardware, see here.

I understand what you mean. I understand there’s nothing you can do to change things directly. And I appreciate your help on configuration.

I also appreciate that you have pull with Qolsys and, and appreciate your reporting to both that standard z-wave devices need to work correctly on their platforms.

Reporting a two function device as a two function device isn’t really the problem I think. Not correctly assigning the two functions, seems to be the problem.

If the on/off function in the panel or app turned the outlet on and off, and the slider dimmed the led, we wouldn’t all be brainstorming this today.

As the op reported, this switch works fine with other hub systems, so I don’t think it’s an aeotec problem. I’m looking forward to serious Qolsys and feedback.