HD100 Wireless Config ADC

Added a new 2GIG HD100 to my ADC account. Wired to router, can see streaming video. However attempts to connect wirelessly consistently fail, resulting in blinking red led and no connectivity to ADC. Tried rebooting network, router, factory reset of camera, multiple deletions and reinstallations of camera, no joy. Any tips?

Have you verified the wireless network key you are typing works on a different device?

Also, the camera needs to be power cycled after adding wireless settings, so if you are just unplugging the ethernet cable it may not connect.

Other than that there are very few variables. Do you have any additional wireless Access Points in the location that utilize the same wifi credentials? I know one circumstance where a camera endlessly switched back and forth trying to connect to two wifi access point devices at once.

I had to create a virtual interface network on the 2.4ghz band just for the cameras (which I then set up with AP isolation). I use a DD-WRT which allows me to create an unlimited number of virtual interface access points on both the 2.4ghz and 5ghz bands.

I also reserved the Mac addresses to create static IPs.

I use 20 plus digit random alpha numeric with symbols AES PSK WPA2. The cameras will not accept anything that is not alpha-numeric. No symbols allowed… hence a weak passcode necessitating AP isolation.

Yes, this is also true. Special characters are not supported in the network key. (I’m not a huge fan of this) But I don’t think that would be the issue here because Alarm.com will not allow you to save the network info with a special character listed and prompts you to change it.

Ahh, almost forgot.

There is also a limitation on character length. When I first set up my cameras, I tried to increase the length of the key to 30 digits when I created the AP.

It will cut it off if its too long, and will not prompt. This made it very difficult trying to connect to the network. It kept failing because the cameras couldn’t get the entire key.

I dont recall the limit… maybe 25 characters or so?

That I am unaware of. What model of camera were you using that this character limitation occurred on? I just created a 50 character key and a 520IR connects without issue.

I have a 610pt (G) and 520ir (N). May have been the 610pt as that was my first camera.

In any event, OP’s inability to connect wireless is almost certainly an issue with his network config (or failure to restart).
Could be something as simple as the key is wrong, to MAC filtering, encryption issue, to having a 5ghz band AP only, to a firewall setting.

2.4ghz band only
Wireless N or mixed?
No wireless AN config
No symbol/special character key
MAC filtering?

Also using DD-WRT on a N7000

2.4ghz band only YES
Wireless N or mixed? No
No wireless AN config Don’t understand this.
No symbol/special character key Had “@” symbol, a printable ASCII character - THIS WAS THE PROBLEM
MAC filtering? No

I don’t mind tech stuff but ADC accepting a password that doesn’t work without documenting this fact is pretty poor documentation in my view. I wasted a lot of valuable time on this. Forum invaluable.

It is definitely frustrating that it let you save the key with a non-functioning character. I’ll shoot that to Alarm.com to look at.

No wireless AN config Don’t understand this.

My bad.
I meant NG … (NG-Mixed)

Wireless N or mixed? No

You do not have the DD-WRT AP set for wireless N or mixed?

If you have all wireless N devices, set to N only, if you have A, B, G and N set to Mixed. My understanding is the HD100 is wireless N