GE zwave outlet not turning on/off?

Hi all,

I have three of these

GE Enbrighten Z-Wave Plus Smart Outlet Receptacle, Works with Alexa, Google Assistant, Tamper-Resistant, 1 Z-Wave + 1 Always On Outlet, ZWave Hub Required, 14288,White

added in on my qolsys 2 panel. The seem to send a receive commands fine, but, the bottom outlet which is the one controlled by z-Wave, does not ever turn on when I turn it on using the app.

The LED light on the outlet is always off too. If I push it and the LED light stays on, then the bottom outlet is always on, and can’t be turned off by z-wave.

Now I have tried to remove one from the network by clearing it, but it never seemed to disappear and then I added it back, so now it seems to be in twice??


Thanks, Greg

Happy to assist! It looks like the duplicate fell off and is no longer showing up in If you are still seeing this, you will want to log out of your account then log back in.

Additionally, commands to re-sync Z-Wave devices have been run and the wall outlet appears to be connected at this time. Can you confirm?

Was a Z-Wave Network Rediscovery Run after learning in the device? If not, do so now. Steps on how to do this are found below:

The LED light on the outlet is always off too.

Per the manual, the light is on when the load is on, by default. If you send remote commands at this time, does the switch turn on? If so, does the light turn on?

If the device is still no longer working after the Re-Sync Commands, run the network rediscovery and try again.

Should the device fail to work after that, then you may need remove the device from programming (method found above) re pair then run a network rediscovery. After doing so, any change?

Hi Tyler,

thanks for the reply!

So what is happening is the load seems to only be controllable by pressing the led light/button. I can manually turn the load on or off. No commands from the panel have any effect when I manually turn the outlet on/off.

I am not at home so I can’t do the network rediscovery yet, but when I get home I will give that a try and let you know if that helps.



Hi there, so I figured out the problem. All my fault… so the outlet I thought was on the network was actually not. So I added it and everything is working properly.

In general though… the led buttons on these outlets are very sensitive. If you push it in just slightly too long it doesn’t clear or add. I thought maybe they were broken. Once I figured out the right amount of time to press the button it was easy to get all the rest working.


That’s great to hear! Hopefully someone else can benefit form this too, regarding the button press time for inclusion.

I have never used that specific device, but my experience with Z-Wave in general is mixed when it comes to inclusion buttons. Sometimes a quick tap is all thats needed but it varies from device to device.