GC3 ZWave Secondary Controller Devices Not Showing in ADC

Hi! Last night I moved my ZWave controller from my GC3 to Home Assistant and made the GC3 a secondary controller. The ZWave devices show up correctly in the GC3, but they are not populating in ADC.

Can you check on the status on ADC and push an update to ADC again?


Of course. We’ve requested an updated list from the system and it looks like the Z-wave device list is populating correctly in the account. You may need to log out and log back into Alarm.com to view the changes

That worked! Thank you.

It says my lock does not have a secure connection so I will try removing and re-enrolling it.

As a follow up to my earlier posts, I continued having issues with the Yale YRD210 lock. I removed it from the primary controller (Home Assistant) and readded it using the ‘secure add’ feature. I then repaired the secondary controller, which updated the z-wave device list and also upgraded the GC3 firmware, which rebooted the system and caused the lock to show up on ADC.

But when I look at the lock on my alarm.com app, I am getting the following error: “Secure connection not established during enrollment. Try deleting and re-adding the lock, or contact support.” The app then gave me a chance to lock/unlock it, but when I tapped “unlock” the app said the lock “is not properly enrolled.”

The Home Assistant primary controller, which is able to see the lock and both lock and unlock it. Before I moved the lock to Home Assistant, it was working perfectly fine with the GC3 as the primary controller.

Any insights? Does the lock need to be properly enrolled in both the primary controller and secondary controller?

The lock should be added to the primary controller within 6 feet of the controller.

Are you adding it within that proximity? This proximity is crucial to properly learn in the device and complete secure key enrollment.

I just started from scratch on the 2gig side. I did the following (all within 6 or less feet of the lock, primary controller and 2gig panel):

  • removed lock from primary controller
  • removed 2gig panel as secondary controller
  • reset zwave controller on 2gig panel
  • re-added secure the lock to the primary controller
  • re-added 2gig panel as secondary controller

UPDATE: lock and other z-wave devices do show up in the ADC interface, but when I click “LOCK” or “UNLOCK” in the app I get the error that “the device Lock (ID:15) is not properly enrolled.”

What is the status looking like on the ADC backend? Any other thoughts?


Commands have been sent and I am seeing several Z-Wave devices populated. However, the Z-Wave lock is still reporting that it did not successfully complete secure enrollment.

When learning in the lock, you will want to leave the lock in close proximity to the panel for a few minutes after learning it in to complete secure enrollment.

If this has been done, there is a strong possibility that the home assistant is not passing the secure command classes to the GC3 and may not be compatible in that way.

What you probably did is add the 2gig as a secure node in Home Assistant and setup the 2gig as a secondary device on the panel. I also have this setup. I have come to understand that home assistant does not support secondary panels (I think this is right). What is happening (to the best I can figure) is that Home Assistant is allowing the 2gig to pull the device list but not allowing the 2gig to communicate with secure devices. Any secure device in Home Assistant will not work at the 2gig. That being said, all non secure devices have worked great. I am not sure if it is because of no secondary panel support in Home Assistant or the fact that Home Assistant uses open-zwave and I am guessing 2gig doesn’t.

Anyway, I would be interested in working with you to do whatever necessary to get the two to speak nicely to each other.