GC3 Voice Announce

I just finished setting up my new GC3 and can not find a way to stop the voice announcement when the system is armed/disarmed. I can stop the announcement for sensors by setting the chime for each sensor to disabled. This was very simple to change globally on the GC2 with both Voice and Chime check boxes on the Security Menu screen. Where are the options to control these?

Currently, there is no way to completely silence the voice announcement when the system is armed/disarmed. You can turn down notifications in the sound menu but this will not completely silence the voice.

The best option is to toggle the “Silent Exit” switch below the arm stay/away buttons at the panel. This has to be done each time as the toggle does not remain in the off position after the arm stay/away.

@Jason_Carnahan Has this issue been resolved with the GC3? I have every volume and voice control muted and it still says “System Disarmed/Ready to Arm”. You can do Silent Exit when arming but no way take the voice out of disarming.

The System Announcements slider in the volume settings doesn’t turn off the announcement volume, there is a minimum value. There is no way to completely silence this. This is the intended function of the panel, but there are certainly situations you might want it to be silent.

We’ll forward this as another user request to 2GIG to be able to silence arming status announcements!

Yes, I try to go to the gym early in the morning and my main panel is in the bedroom. It wasn’t an issue with the GC2. I could disarm the panel silently and sneak out. Now my wife is not a huge fan of the GC3 because of this.

Thank you for forwarding the request. Seems like this request has been around from 2016 since the panel came out.