GC3 LTE sled upgrade failure

I installed my new LTE sled today and it was working for a while (I think). I installed per instructions here, Not what the paper instructions said to do. Then I noticed a dual path communication failure. I have tried disconnecting for 20 min per what I saw in another thread on here. The radio test comes back “Cell radio not detected”

I am running FW 3.2.5

Seems to communicate via wifi, but not through the LTE sled at all

Same issue here. My system is completely unusable because of the constant beeping 24x7 about the communications issues.

Is there no support here on the weekend?

At this time tech support is offered during office hours, we are looking at expanding that.

I’ve seen this on the GC3 with upgrades either using the power down swap or using the built in swap process in the software, however it would be good to try the opposite method and to remove and re-install the module to ensure a good connection.

The module can sometimes be inserted but not pushed in fully, make sure the module is firmly pushed in all the way. Make sure there is no debris or dust in/on the connector.

What firmware was your panel on previously?

Same issue here. My system is completely unusable because of the constant beeping 24x7 about the communications issues.

@tpetersen It looks like you have replaced the panel with an IQ, is that right?

I have tried both swap methods multiple times. At least 5 times. I upgraded to FW 3.2.5 a couple weeks ago. My panel is a GC3.

Just in case, double check in the GC3 panel for debris or dust in the connector port. It sounds like your panel is just not recognizing that any module is inserted.

Check the male connector on the module too. Just make sure there are no smudges or dust on it and inspect for any damage just in case. Wipe it off, insert it with the panel fully powered off, make sure it is very firmly attached and can’t be pushed in any further. Any luck after a boot up?

I’ve seen this issue pop up intermittently since the release of the GC3, it is usually resolved through physical troubleshooting and power cycles. My guess is that it would be an actual physical issue or a problem with the module if you have the latest firmware and no results from other troubleshooting.

Ok, I’ll try that again this evening. If that doesn’t work what is my next step?

Can I revert back to my 3g sled and return the 4g sled for a replacement?

Yes, if after cleaning and power down, reinsert does not resolve the issue, we can help with an RMA and replacement.

What should I clean / wipe it off with?

Just a clean dry cloth, it is probably more likely to find dust in the port in the panel.

It is a long shot, but given what you have described trying so far I would guess obstruction or a loose connection to the port.

No luck here… The sled was fully seated in. I cleaned it off. There was no dust in the port. I sprayed it out anyway with a can of air. Still the same issue. Can you start the return process please? I was not able to revert back to the 3g sled. System said unable to install 3g after June of 2019. Is there a way that you can revert me back so this will work while I am waiting for the new sled?


Yes, I can swap you back manually until you have a replacement module. I have switched you back to the 3G previously in use on the account. You can run a cell test with the 3G module now.

Our team will reach out with RMA instructions via private message.