GC3 Button issue

I installed my 2gig gc3 and it appears to be malfunctioning. The two buttons on the right (+ and square) seem to be pressed randomly and consistently. I often hear the panel beeping like the buttons are being pressed and i look over and it’s at the panic/fire/emergency screen. I go to the device and hold or press the bottom button a few times and it comes back to the main screen.

Well that is very strange. The buttons are touch buttons and do not get pressed inward like the GC2 so they should not get stuck. Have you been able to see the panel go from one screen to another? Is there anyone else in the house using the system?

Have you tried fully power cycling the panel? Unplug the power transformer, then unplug the battery, then plug in battery, then plug back in the transformer.

By touch buttons, do you mean they’re capitative or resistive? Could they simply be dirty and need to be cleaned?

I have made a video of the issue that can be seen here:


They are capacitive I believe. The lightest touch should activate the buttons. Thank you for the video, it helps get an idea of what is occurring.

A few questions:

Are you using the included 14 Vdc transformer to power the panel?

Have you power cycled the panel, transformer power supply and battery?

It looks like you are applying a good deal of pressure on the buttons, do you need to in order to get them to register?

yes, I am using the included transformer and have power cycled the panel by killing the breaker and pulling the battery numerous times. it boots up and acts the same. They buttons move between not registering or constantly pressing. as we speak, i’m looking at the panel switching between panic and home screen repeatedly.

Do you have a multimeter to test the voltage reading at the panel?

How far is your cable run and what gauge of cable are you using?

I’ll see if 2GIG has any knowledge of this as a potential issue. Do you have any other devices wired into the terminal block on the panel? Any hardwired zones/sirens etc.?

The cable is 12 gauge (all i had, i don’t think too big of a gauge could be a problem, right?)

the cable run is about 6 inches as I have the panel mounted on top of a recessed outlet.

Nothing else is hardwired into the panel, just power.

and yes, i checked the transformer with a multimeter and it registers 14v.

A larger gauge shouldn’t pose a problem on paper, but I’m surprised 12 actually clamped down in the terminal block. Is the contact to the transformer screws solid?

Alright, yeah if you can verify the voltage at the panel then it looks to be a panel issue. Either software or hardware. I’m discussing with 2GIG to confirm any other troubleshooting steps.

EDIT: just re-read, it sounds like you directly tested voltage on the transformer. You’ll want to test the DC voltage at the panel pins. Can you verify 14Vdc there?

yes, tested the voltage at the pins. same reading.

I have not heard from 2GIG again yet, however it is certainly an issue with the panel. By chance have you tried to power down completely and remove the cell card, then power back up and see if the problem continues?

Our return and warranty replacement policy is found here if purchased through us.

Just on the off chance the module is involved I would try removing the module and powering up the panel, but should that result in no change you will want to get a warranty replacement.

Tested with the card removed and the issue persists. I will be returning the panel for refund and ordering a new panel to be shipped today. I plan on keeping the cell card and using it in the new panel.