Failed firmware update

I have a 2gig system with a Control Panel and a TS1. I bought second TS1 to add after a year. The original 2 panels were running v. 1.9.X of the firmware and working just fine. The new TS-1 I bought was running 1.10X. So I thought to myself, "self, this is easy. Update the to older panels to 1.10X and everything will be fine.

Well, the updates ran fine, the units all report having 1.10X firmware, but the first hint that something was wrong was when I brought the system back up, and powered up the old TS-1, it didn’t find the CP. Neither does the new one.

So next, my self says “no big deal, just re-pair them and we’ll be good to go”. So I reset the TS-1, got the “unpaired” startup screen, and tried to pair them. No joy. So I took the new TS-1 and tried it. Also nothing.

After posting on the 2GIGForum, I removed all entries in section 04 of setup, and tried again - nothing. Next advice was maybe I damaged the XCVR2 module during the update, so tried a new one - no luck.

So, I reset the CP back to defaults, still nothing. It behaves like the radio is not working, but it began with the firmware update, and a new radio module doesn’t help. The CP talks to the rest of the sensors without any problems.

Any help is appreciated. I’m trying to avoid buying a new CP at this point, but I’m out of ideas. I’ve done this kind of thing many times over 35 years of working with computer components and systems. I’ve never had firmware updates work, but then have the hardware not perform as it’s supposed to.

I have seen this precise issue exactly once before, and the cause is hard to nail down, however, in that case a recent firmware update had also been applied. I went through the steps you’ve listed to the letter. The Control Panel ended up getting swapped out.

Have you tried re-flashing the firmware? If you are able to, I would suggest trying that first.

Great, so I get to be in the category of “rare exceptions”. Not where I want to be. :frowning:

I have tried re-flashing, no luck. I suppose I’m ordering a new CP.

Well, now that I know of two identical cases I can get a bit more attention from 2Gig. I will update this thread with any response.

Just so I can give them the best information possible, I have a couple questions.

  1. What was your order of updating equipment?
  2. When the first piece of equipment was being updated, was the other one powered up as normal?

I powered everything down (all panels), then updated the old TS-1. I confirmed that update was showing the right version, powered it down, and ran the update on the panel. That’s all I was expecting to do. The new TS-1 was already at the newer firmware.

Then I brought the CP back up, checked it’s version (it reported the new version number), and checked to be sure that it was talking to the sensors. That all seemed fine. Then I powered up the old TS-1, and it wasn’t talking to the panel. I re-set it and tried to re-pair it, which is when I started into serious troubleshooting mode. I tried the new panel - no luck. That’s when I started posting on the other Forum, looking for help.

Do you think the 2 TS-1’s are likely OK to talk to a new CP? I’m getting ready to order a replacement CP from SuretyDIY. Is it worth waiting a bit to see if there are any other things I can try?

Well, I will be forwarding the issue to 2Gig, but I can’t promise when they will have an answer as it is clearly a rare scenario.

I can tell you that in my prior case, there were also two TS1 keypads. In that scenario, both were existing. (I had tried a brand new one with the panel in the course of testing, but similarly that didn’t work.)

When the panel was swapped, both TS1 Keypads functioned.

Ok, I’m going to go ahead and order a new CP. Can I be sure that the CP I order from SuretyDIY is already running 1.10?

Yes, all panels we currently ship out are 1.10.X

Thanks for the help. Once I get the new panel I’ll post to let you know if it works or not.

OK, so I got the new CP, and it started up and talks to my TS1’s (and everything else) just fine. Don’t know why the old panel failed to do so after the firmware update. I’m happy to provide serial numbers or whatever you need if you’d like to report it to 2GIG. I moved my modules (cell phone and XCVR2) over to the new panel, and both seem happy. Whatever the problem is, it’s in the CP. Something in the new firmware isn’t compatible with that CP. One difference I noticed is that the old CP had a POTS interface built into the board. The new one doesn’t. Maybe that’s a clue?

I do have another question. My motion sensor (PIR1-345) seems to be acting strangely. After configuring the new panel, the motion sensor seems to be working randomly. I don’t remember it doing behaving like it is right now when I originally installed this system. If I use a magnet and put it in test mode, it seems to test fine, but when I try do a walk test on the system, it only trips sometimes. Once it detects motion, does it have any kind of timeout that has to expire before it will trip again? I also thought I was remembering that when it detected motion the red light blipped on. That’s not happening unless I use the magnet to put it in test mode.

The PIR1-345 will not flash its LED unless in walk test mode. And yes, there is a period of downtime when the motion will not activate. When testing, we recommend allowing 2-3 minutes since you’ve walked past the detector, then enter the area the detector is facing to test.

Most battery operated detectors will function this way. Hardwired DC powered motion detectors are more immediate as there are no power consumption concerns.