Delay in ADC lock rule not working


I have the IQ Panel 4 and a Schlage Encode wifi deadbolt. I configured a rule to lock the deadbolt after arming away with a 3 minute delay. In ADC it looks like this:

The locking works, but the delay doesn’t. I arm the system, walk to the door, open it, and the deadbolt comes out before I have time to close the door - probably 10 seconds tops. Any ideas what would cause the delay setting to be disregarded?

I am not sure what specific error that would cause that, but the first three steps I would recommend are the following:

Power cycle the lock.
Delete the rule in Wait 5 minutes. Recreate the rule.
If no luck, delete the lock, wait about 5 minutes, then relearn the lock.

Let me know if you see the same behavior after those steps.

Just to be sure, how are you arming the system? At the panel? App? by Scene?


Apologies for the delayed response. I did try your suggestions and it didn’t make a difference. I’ve tried creating the rule with both the “rule based” and the “event based” options and it behaves the same. Furthermore, I actually have 2 of these locks and tried the same rule on the other lock, and the same thing happens. No matter what delay I specify in the rule, it locks immediately.

I’m arming the system at the panel. I have rules for both Arm Stay and Arm Away and the same issue occurs on both.

Did you also try deleting the lock and pairing it again? Those locks still show as having an install date prior to that suggestion. We would want to be sure that step is completed as will recommend it first.

My apologies (again) for the delay- this took a while to do and I just finally got around to it.

I unpaired the locks and deleted all the rules and repaired the locks and recreated the rules. It still doesn’t work correctly. The locks are still locking within about 10 seconds of arming the alarm, even with a several minute delay specified.

(Note that I have disabled one of the rules after testing and confirming it didn’t work, because the erroneous behavior is super annoying :))

Alright, thank you for testing, I am sending the info to The rule processing is all on the back end through ADC and Schlage, so most of the same troubleshooting steps for Z-wave locks won’t apply. It sounds like there is likely a calculation bug.

In case they ask, what all delay options were tested?

Thanks Jason. Originally I was testing with 3 minutes. When I re-created the rules I used 2 minutes. I’m pretty sure I’ve tried at least one option in between as well.

Thank you for confirming, is investigating this.

Hi! Just wanted to check in and see if if there was any expected next steps on this. Thanks.

Not yet but I will follow up with and see if they have any info.