Communication Module Stopped Working

Our cellular module seems to have stopped working since Saturday. We’re not sure how to test it, and intended to call the SuretyCam helpdesk. Can you point us to an article that will help us get started with troubleshooting? The 2GIG control panel started to beep in the middle of the night, and it said that we’d lost connectivity, so my husband disabled the card.

I just spoke with Alarm.com and they informed me that AT&T is beginning to reduce the 2G coverage in your area. While your zip code is not specifically on the list of areas that this is effecting, it is directly adjacent to 3 other zip codes that are. It’s possible that the tower your communication module was connected to is no longer providing solid 2G service. At this point we have a couple of options.

1.) Power cycle the panel. When the panel powers back up, it’s possible that the communication module will find and connect to a different tower that is providing 2G service on a stronger and more consistent basis. In order to power cycle the panel you will need to:

1.) Open up the panel.
2.) Unplug the backup battery
3.) Remove the panel from AC Power
4.) Wait 15 seconds
5.) Plug the backup battery back in
6.) Return AC Power
7.) Close up the panel.

After that, simply run a cell phone test and it will hopefully connect to a functioning tower.

All that being said, this is only a temporary fix (if it works) and 2G service will probably be gone from the Atlanta before too long.

2.) Purchase an update cable to update the firmware on your panel. Your panel is currently running firmware version 1.5. The newest version is 1.10.1. After you update the firmware, you will also need to purchase and replace your 2G module with a newer 3G communicator. Here are links to our DIY store where you can get the update cable and the communicator module.

Update Cable: https://suretyhome.com/product/2gig-usb-firmware-update-cable-ts1-4-pin-extender/

AT&T Module: https://suretyhome.com/product/2gig-alarm-com-att-3g-hspa-communicator/

Verizon Module: https://suretyhome.com/product/2gig-alarm-com-verizon-3g-cdma-communicator/

I didn’t realize that our installer had only put in a 2G module. We had it installed less than six months ago.

Do we need the update cable in addition to the 3G communicator? Do you have a recommendation for Verizon vs AT&T in our area?

The equipment your installer put in is using very old firmware. Your panel firmware needs to be at least up to 1.9.6 in order to use a 3G module. In order to update the firmware, you will need to purchase an update cable. Additionally, your area seems to be good with either Verizon or AT&T. I would pick Verizon because it seems to have a consistently stronger signal and as a bonus it’s cheaper.

Yep, 2G cellular modules are dropping offline overnight everywhere. This issue you are having will become widespread and massive within the next year or so

Need the 3G module, and your firmware is old, your panel is missing a lot of the newer features/functions, and can’t even run the newer gear/sensors/hardware (ts1 touchpad/keypad, newer cellular modules, the new motion detectors aka image sensors, zwave device compatibility and zwave lock fixes, and all the other fixes and tweaks the newer firmware versions addressed, etc)

Celular module replacement walkthrough see: http://www.2gigforum.com/threads/4-2GIG-alarm-com-3G-Verizon-3G-AT-amp-T-cellular-modules

And firmware versions/downloads (v1.9.6, v1.10, v1.10.1) see:

Once you update firmware,you should optimize your panel, and fully enable it, download the how to guides, instruction and programming manuals, etc here is how:

We’ve updated the firmware and replaced the cellular module successfully. We’re getting a radio signal of 19/31, which appears to be decent. We did the cell test as well. Everything seems to be working, except alarm.com says ‘panel not responding.’ We tried calling the central station to check whether they could see the new module, but they kept transferring us to your office, where we got a recorded message. We can arm the panel, but it doesn’t look like we’re connected to the central monitoring station at present. What do we need to do to fix that?

In order for the new module to take effect, it has to be activated on our end. I just went ahead and did that. In order to finalize the module swap you will have to power cycle the panel and then run a cell phone test. In order to do this just follow these instructions.

1.) Open up the panel.
2.) Unplug the backup battery.
3.) Remove the panel from AC power. This can be done by simply unplugging the transformer for the panel.
4.) Wait 10 Seconds.
5.) Plug the backup battery in.
6.) Reapply AC power to the panel.
7.) Once the radio is showing a signal, run the cell phone test.

After that, you should be good to go.