Can't set Kwikset user codes from

I have installed two Kwikset 910 Z-Wave SmartCode Electronic Deadbolt locks and when I assign a code to a user in those codes won’t open the locks. I can lock/unlock but not use individual user codes. I have alot of people coming in and need to manage this by user not use a general code manually programmed into the lock. FYI - I have exactly the same thing in my other home and it works fine. Help.

Are the user codes you programmed in working to disarm the 2GIG panel?

Yes. And when I manually add the code into the lock with the program button the alerts show the correct person unlocking the door. Also I can lock and unlock the doors from my phone and online.

That is strange. How long are you waiting after saving a user code on before testing it on the door lock? It might take 5 minutes or so for the new code to be sent to the lock.

On your panel it looks like there are 4 users, 2 of which have access to the lock all the time, one of which has access to the lock on a time schedule and the other has no access to the lock at all. None of your users have access to the second lock at all. Is that the way you want it to be? If not, log in to and go to Security -> Users. Look in the second column to see which users have access to which locks and when.

I am monitoring the “pending” status on and waiting for more than an hour.

Your description of the above is correct. I also confirmed all have “slot numbers” per

When I enter the user code for me (which is not hard coded into the lock) the lock is non-responsive.

I even created a “test” user, waited until I could see them on the panel and in and tried the code on the locks, no response.

Is there some daughter board issue do you think? I know that some of the Kwikset locks have Zigbee AND Zwave functionality - could that be the issue?

I don’t think the Kwikset 910 can have both. I think it’s either Z-Wave OR Zigbee.

The Kwikset 910 has always been a very proven and well tested lock in terms of compatibility with 2GIG and

Could there be a communication issue? I think programming commands are larger messages than unlock notification messages. Maybe the larger programming commands aren’t getting through to the lock but the smaller commands like lock/unlock are? How far is the lock from the control panel? If more than 30ft, would it be possible to bring them closer together and run a test that way?

Another idea (but a long shot)… I know changes were made to 2GIG and recently to support the new 10 digit Kwikset locks (913 & 916). I wonder if any of these changes caused a problem with the 5 digit locks. Could you try some really simple user codes for testing like 0000 and 1111? Again, it’s a long shot.

We might have to wait for help during business hours from 2GIG and Kwikset on this one.

I moved the panel to about 6 feet away - I can move it closer and see if that helps. Understand the payload of the data. I tried the code 1234 as a test user (twice) and that didn’t work. Would be curious to see if Kwikset or 2GIG have this as a known issue.

How far away were the locks when they were learned in to the panel? I see a fair number of issues with lock communication where it partially functions when the pairing process was not 100% successful. It may sound strange, but I would suggest the following:

  1. Remove the locks from the panel.
  2. Move the panel and locks within just a few feet of one another.
  3. Add the locks back to the panel.
  4. Put the devices in their permanent spots and run a network rediscovery.
  5. Send codes to the the lock on and test.

Ok, I’ll try that. Please expound on step 5 - does this mean I need to remove and add back the users with the codes on

Your locks will have new node IDs and will be selectable as new locks in the user management screen. You would select to give lock access to existing users and save.

This did not work. Now when I add new users they never show up in the panel as new users. I have delete all the users except the master, removed the lock, added it back, added new users, associated the locks and still doesn’t work.

Please define “run a network rediscovery” - is that Services>Zwave>Check Network?

When do I get to talk to a liver person about this issue that is making my alarm system inoperative?

This is a network rediscovery.

It looks like currently the only user given access to the locks is the master user. There are a couple others created but no access was given. Did you give them lock access before to test and later removed it?

Here is a video describing the user code page.

Just in case, I have sent an additional command to try and clear communication. Can you give one of the codes lock access, save the change, wait 5 minutes, then try the code?

When do I get to talk to a live person about this issue that is making my alarm system inoperative?

There is no “live phone tech support” for DIYers…

Q: But I’ll get helped faster if I call, email or live chat you directly, right?

A: No. If you call, email or live chat you’ll reach our customer service representatives. They will not be able to answer your technical questions. They will not transfer you to a technician. Our technicians live on the forum and only on the forum. Post on the forum and avoid the frustration of dealing with someone who can’t answer your technical questions. If you have questions about a particular order or want to update your personal information then use live chat or email

So now the panel won’t acknowledge users that I input into after over an hour.

Update: I’ve added users in and waited over an hour, checked slot numbers and it’s not there. Checked the panel and the user is not there. Advice?

Is your panel having intermittent communication issues with ADC?

Might want to check to see if your panel has a cellular signal issue/or is roaming (roaming can result in intermittent communications/signal drop/etc).

If signal is less than say 15/31 consistently (drops below 10/31), that’s a problem, and might explain why changes made on ADC do not reflect on panel (after an hour?) and vice versa. This may indicate signals not being received or sent.

If signal isn’t good (e.g., 20/31), an option to resolve your problem may be to add a Go! Bridge.

If on the other hand, signals are consistently decent (15/31 and over), the problem may need pushing to ADC for resolution to determine why signals/commands sent from ADC are not being received/properly implemented by the panel/zwave device.

Your cell module signal strength looks good. I see 2 users on your and your panel is reporting that it has those same 2 users.

I’ve added users in and waited over an hour, checked slot numbers and it’s not there. Checked the panel and the user is not there. Advice?

I see both users on your panel. What method are you using to check the panel user slots?

The users are showing up now on the panel. However the codes I assign at still don’t unlock the door. Can we reset the panel? What is the exact order of steps to use if we can’t reset the panel?

Can we reset the panel?

Do you want to reset the panel itself, and/or reset the zwave controller?, or have ADC lock info “reset”/repushed to panel?

To reset panel:
Push SuretyCAM logo on screen/enter installer code/restore defaults.

alternatively, power panel down, reconnect battery, and at same time you reconnect AC transformer, hold both Home and Emergency buttons (requires Q45 lockout to be disabled “0”).

the above will reset all programming (Q)uestions, configuration settings to factory default (console), and/or remove all programmed devices/sensors (zones) depending on the checkmarks (selection).

to clear and reset zwave controller (removes all mesh network zwave devices):
services/zwave/wrench symbol/enter master or installer code/advanced toolbox/reset controller

I see that the master user is showing as having unlocked the lock a few times. Is the second user code still unable to unlock the door?