Alexa & device discovery issue

I’ve had an issue for a while where I must say “tell” to get light commands to work. It used to work and stopped one day. I have both skills enabled and linked.

Today I tried removing both skills and re-setting them. Unfortunately, the smart home skill that does the commands without the “tell” prompt can not detect any devices. The other skill is enabled.

Happy to help!

When adding devices to the Smart Home Skill did you:

  1. Open the Amazon Alexa app.
  2. Tap the Device button in the bottom right corner
  3. Tap +
  4. Tap Add Device.
  5. Tap Other.
  6. Tap Discover Devices.

You can also try to discover devices by saying, “Alexa, discover my devices.” Does this work?

I have tried both and it does not detect new devices.

Just to be clear, there are no new devices and everything works as it should in app.

Correct, devices are populated in ADC.

The Alexa app is not detecting them at all? When clicking on Devices -> then the All Devices… button, are any of the relevant Z-Wave devices populating? Have you tried power cycling the Echo device and trying again?

Yes, devices are listed. However, it’s missing some and names are not sync’d with ADC.

Note that the Smart Home Skill for Alexa (which eliminates the “Ask” portion) is only compatible with lights and thermostats. It cannot be used with locks or other devices. That may attribute to the missing devices.

Yes that is correct, however “Alexa turn off the kitchen light” (for example) does not work. It says “sorry, something is wrong. To control kitchen try disabling the skill and re-enabling it in the Alexa app”. Which I have done multiple times now.

The next thing to try here would be to remove a device from the Alexa app as a test. Preferably one that you know works, and worked in the past with Alexa before.

To delete a device, go to Devices on the app, click on the individual device, Settings, and then the Trashcan icon.

Once the device has been removed, Discover the device again via the means above.

Does Alexa discover it and more importantly, can you control it?

I removed my upstairs thermostat and tried to rediscover it, but it does not find it.

Odd thing is, I can still control it with the “tell” skill.

Removing it from the Smart Home Skill may not affect the regular skill.

Regarding the Kitchen Light control, I am curious if this might be a limitation with voice control interpreting intention. You have two lights starting with the word Kitchen, and “light” is used as a generic term appended to all lights, which the system may not handle correctly as part of the name.

Try changing the name of Kitchen Lights to something like “Kitchen Overhead” and try “turn o the Kitchen Overhead lights”

Any luck?

I renamed “kitchen” to “Dog” and then said “Alexa, turn off Dog” and it said “sorry, something is wrong with Dog, try disabling the skill and re-enabling it in your Alexa app”.

So it recognizes that I renamed it.

My upstairs thermostat is still not in the list.

Which Alexa enabled device are you using and have you tried power cycling it? Any change?

Renaming the devices has had no effect. Neither has removing devices from the alexa app to rediscover them, correct?

If power cycling doesn’t fix the issue either, then its likely that the Alexa enabled device would need to be factory reset and integration started over.

I have two Alexa devices, which have been power cycled over the months that it hasn’t been working, but I will try again. I guess I can just remove the skills, factory reset and start over but wow that’s a pain :frowning:

I just noticed you have 2FA active on your primary login. Can you try turning off 2FA in settings and see if that allows you to discover devices through the Smart Home Skill?

This is under Settings > Login Information > Two Factor Authentication.

DING DING DING!!! You’re a winner! :slight_smile:

Great! Yes, 2FA is compatible with the Alexa Skill, but not with the Smart Home Skill (I think this is caused by an Amazon policy, but we’ll update the forum if support for 2FA changes.)

If you want to use 2FA for your primary login, you should be able to create a secondary login that has access to lights and thermostats which does not use 2FA and link that with the Smart Home Skill instead.