second lock rule not working!

I have a 2GIG control panel which works with I have 2 locks, lock #1 Front Door, lock #2 Side Door. I have 2 rules, one that disarm the system when an unlock code is entered at the Front Door Lock, that rule works. The second rules does the same for the Side Door Lock, that rule does not work. I can unlock both lock with the IOS app. What could be the problem?


Unfortunately the Panel does not have a way of visually indicating rules were successfully saved when created. In this case, deleting the rule, wait a few minutes, and recreate the rule is the best troubleshooting step.

I am not a big fan of zwave locks, (and I am trying to get rid of the one I have), but I could have sworn if you go into the zwave services on the 2gig panel, and click on The particular lock in question, that there is a box you can check that will enable disarming of the panel when that lock is disengaged… has this changed?

That box is not there if Q79 is set for (3) Remote Access Enabled.

I have in the past set Q79(2), created local rules for automation (lights on for alarm event), then reset it back to Q79(3) and the locally created automation rule was still running, without having to recreate the same rule on ADC, (and later when I reset Q79 back to 2, the rule was still there). So changing Q79 didn’t enable/disable rules, it just hid them.

So an option, may be to set Q79 to 2, go to the zwave services , and select the lock, and check that box for disarm when lock disengaged, then reset Q79 to 3.

(on a side note, It makes me wonder if setting Q79(2) enables any more functionality for tstat (T2000) then is currently available locally on the panel with Q79(3)…fan auto/on, mode auto/heat/cool, and manual hold setpoints.)

I changed the Q79 setting to 2, and checked the box in the z-wave menu for the lock disengaged. Set back Q79 to 3 but still the same problem. Even if I leave Q79 set to 2. Strange thing, I can set users code for the front door lock on the Control panel but when I try for the side door lock, I get this:
“Confirmation of the new code was not received from the door lock. Please click OK to try again.”

When I click on the refresh button for the user code it says unassigned.

That would likely indicate one of two things:

A signal issue between the panel and the second lock, or the second lock did not properly or completely sync with the panel during the learning process.

I would recommend bringing your panel within a few feet of the lock, removing it from the panel (services - zwave - wrench - remove device - perform the sync process on the lock) then re-adding it. Make sure to keep the lock and the panel close to one another for a couple minutes for this process. When your panel is back in its permanent spot, make sure to run a Network Rediscovery. This is an important step which is commonly overlooked.

Do you have AC powered repeating Zwave devices in the network as well?

I brought the lock close to the panel, remove and added the lock to the z-wave network. Still can’t set the users code to the lock through the control panel. Same error message.

Is there a reset feature on The lock? Remove it from network, then reset

Well, the reset did the trick. Now everything is working fine. Thanks for the suggestion!

Nice. I like how helpful this forum is.