Mobile App - Home Screen Quick Actions

I would like to configure Home Screen quick actions in the mobile app for
iOS. When I tap on App Settings->Home Screen Quick Actions, I just get a spinning wheel. I tried on another iPhone, same issue. Is this currently a bug in the app? Does it work currently for anyone else?

What phone models, versions of iOS, and what versions of the ADC app are being used on those?

Both phones are iPhone 13 Pro running iOS 15.3.1 with ADC 4.21.8

Thank you, just to verify, on your app are you selecting “Keep Me Logged In” when using your credentials? This is required for Home Screen Quick Actions. If you delete and reinstall one of those apps is there any difference?

I am reporting this to ADC to see if there are any known issues.

I see the same behavior and I am on same iOS version and ADC app version. I have Keep Me Logged In enable. The ADC app install is a first time (ever) install on my device.

Yes, I have “Keep Me Logged In” selected.
I tried deleting the app and reinstalling - same problem.
Just to be clear, using the quick actions by long pressing the app icon works - but those are just the default ones (Disarm Panel, Arm Stay Panel, and Arm Away Panel). I want to configure those to add “Open Garage”, and it’s the configuration screen for the quick actions that I am unable to access.

Thanks for confirming, I’ll give ADC these details and see if they can recreate the problem and determine a fix.

Any update on this? I’m having the same issue.

Can you confirm your phone model and the ADC app version?

I got an update sounds like they were able to recreate and it is currently escalated to engineers. From what I am told it doesn’t affect all iPhones and may not be version related. There is no ETA, but it is actively being addressed.

Thanks. In case it is still useful, I have an iPhone 12 Pro and am on 4.21.14. My wife has an iPhone XR and has the same behavior.

Thank you I’ll add this info. Currently it sounds like they are thinking it is related to account data, not phone model, so it would likely affect any device attempting to use that feature on any affected account. If there is any evidence counter to this let me know as that can help engineers investigating.

Any updates to this?


I have not received a definitive update on this behavior yet. However, looking into your account data, it looks like you have two locks which may be causing an issue.

The Front Door and Back Door locks are reporting in trouble conditions as incompatible.

Looks like they are Schlage locks, which means it is likely due to their manufacture date. Can you confirm the manufacture date of those two? It should be on a label on the back of the lock.

I haven’t had a chance to check the manufacture date on the locks, but the purchase date was December 2019, so they are almost definitely too old (which we noted the last time when I moved from a FE599NX to a YRL226.) The BE469ZP’s have worked flawlessly, so I have been hesitant to replace them.