and Genie Aladdin Connect Issues

I have 2 Genie garage door openers that I had working flawlessly with and my IQ Panel 2, in regards to both control and status updates. The alerts for the door open and close and the door left open alerts all worked. I am now having an issue where one door will sometimes report its status and the other refuses to. I have tried unpairing and repairing, different wifi networks, etc, and am still having these issues. Is this a back-end issue with or genie or something I am missing? When this worked, it worked really well and I would love to have it back. Thanks!

Do you have the retrofit kit with door position sensors?

Issues with the status of doors is common when the tilt sensors used to determine the open close status have low battery levels.

Please try replacing the battery in the sensor, then open and close the door from the wall button.

They are the Genie garage door openers with the built-in Aladdin Connect. They don’t have any battery-operated sensors, but the openers are connected to my home wifi. They correctly report their positions and respond to open and close commands via the Genie App on my iPhone, but they just don’t work correctly with within the last day or so.

Ok, I haven’t heard of any general issues with Genie services through right now, but I’ll check with ADC on that.

If you power cycle your openers do you notice a difference?

Tried power cycling them first, had the same result. I then tried to remove them from the Aladdin connect app and from my account, then re-establish them both in the Aladdin connect app, which works fine, but when they are added to they wont refresh their status, won’t respond to commands and wont trigger alerts. That’s what had me wondering if it was a server side issue between genie and, or is it something on my end.

I spoke with ADC and they are suggesting we remove the account link and have you relink the Aladdin connect account. They said they had a few prior cases where this caused the Aladdin app connection with ADC to sync up again.

Can I go ahead and remove that link now?


It seems to be working after adding them back in. I am getting alerts and am able to control them again. Whatever you did, did the trick. Thank you for the help!

I didn’t actually remove the link, just getting back to this. Prior commands to check the status of the devices may have helped kick it loose or it could have been a hiccup with the API. Let me know if you see an issue with it syncing again.

Will do, sir! Thanks!