alerting for MyQ Garage door unreliable

In the past few weeks the integration with my MyQ 821LM garage controller has become worthless…either it is completely unreliable for opening/closing the door via ADC (e.g. iPhone app) or the alerts are entirely inaccurate.

I have alerts set to notify me if the door is left open, I got one of these alerts the other day when we had left home…we could swear we closed the door, but lets trust our fancy alarm system to know…so I send a “close” command via the ADC app. The alert is cleared and the app shows the door closed. We get home an hour later and the door is open. It is a good thing I don’t have the garage reporting.

Today I am home, but my wife took the car. A little while later I get an alert from ADC saying the door is left open, so I go look. In fact the door is NOT open, it is closed. I look at the app, ADC reports it is open. Who is right?

This is a rather expensive device to not work, what is the best avenue to resolve this? I fear touching the thing as it was a nightmare to even get it registered with ADC the first time (you can see my previous posts).

There are currently no known issues with Liftmaster integration or with the 821LM itself. I can think of two potential issues that might cause these symptoms.

  1. The tilt sensor isn't mounted well or is malfunctioning so it's reporting incorrect open/close status to the 821LM.
  2. The 821LM's Internet connection is unstable.

It sounds like maybe the Internet connection being unstable is the culprit because you say it’s unreliable when sending open/close commands which does not depend on the tilt sensor. If it is an Internet connection issue then it could be the WIFI connection from the 821LM to the router or it could be that the overall broadband connection to the Internet is unreliable. An unreliable connection between the 821LM and the Liftmaster servers could cause these errant door-left-open notification problems because if the 821LM reports the door opening and then doesn’t report the event that the door has closed, will think the door is still open even though it’s closed.

What do the status LED’s currently look like on the 821LM? The blue light should be on solid and the green slight should normally be solid but it might be blinking if it’s currently communicating with your router. If the blue and green lights are both blinking then the WIFI connection is bad.

Another thing worth considering, as a redundant check on the status of the garage door, is adding an RE206 tilt sensor to the garage door.

It seems stupid since you already have a Liftmaster tilt sensor but the RE206 reports through the 2GIG panel and the cellular connection, not through the WIFI/broadband Internet connection, so it would not be affected by any WIFI or broadband issues.

If you think the tilt sensor might be the problem then please attach a photo of how it’s mounted so we can take a look.

The sensor is mounted with the supplied sticky-backed velcro to the top panel of the wooden door. It is as “firmly attached” as the provided velcro could make it. Does the sensor require “sudden” motion to trigger? This is a soft start/stop opener, is there a chance the close action is too soft for it to register?

When I have looked at the MyQ the green LED is glowing solid. During the event I came home to an open garage after “closing” the door through ADC it was also glowing solid green. I hadn’t tried this before, but opened the IP of the MyQ in a web browser and got a status page…interestingly it shows that the MyQ has only been “powered” for <1 hour (photo attached). My power has not been disrupted for quite sometime, I know I rebooted the device a few days ago so it should have a longer uptime. Or does the device self-reboot if it loses WiFi?

I do not believe the broad connection is a problem as I work from home actively using the Internet 10+ hours every day, and then it used actively for most of the evening for other activities. Connectivity from the rest of the network to the MyQ seems ok, <2% packet loss average over an hour shouldn’t break TCP/IP communication. 2% is higher than I would have expected, but I can’t speak to how reliable that device is for responding to ICMP. -72db isn’t perfect, but should be more than adequate for even medium bandwidth needs.

I actually have a RE206 already attached (that i now use to validate what MyQ reports), however the default “wizard” notification rules seem to only look at the MyQ status…I guess I could delete them and use manually created rules instead…of course I did pay a good bit of $ for a device that was supposed to integrate this to my alarm for a reason, if the MyQ won’t work then I may as well look to return it and spend that $ elsewhere.

Not trying to be a jerk, just not happy with an expensive device that isn’t working. Coming home to a garage that was left open due to this security integration failure is not very comforting, I am glad we were only gone for many hours and not many days…and thankfully it doesn’t seem anyone decided to walk away with tools, bicycles, camping gear, the BBQ, or anything else that was for the taking.

Photos of the installation

It just rebooted itself, I am guessing it had been “up” for ~2 hours. Is that expected? A bug? A hardware defect? I’m sure it will be lovely to work with Chamberlain/Lift Master on this.

Scratch that theory, it rebooted at ~50 minutes as well. It seems that either the power supply for the MyQ is faulty or the MyQ itself has a problem. I assume I would have to work with LiftMaster on support since this is past 30-days.

Your tilt sensor looks like it’s mounted fine. Sometimes people mount them sideways instead of upright like you have it, which causes problems. No, it doesn’t need a sudden motion to trigger. It just triggers off angle of tilt. When tilted over it’s considered open. When it’s upright, like in your picture, it’s considered closed.

I’m currently at home and I have no garage (live in the city) so I don’t have one that I can look at the status page and compare with but the rebooting doesn’t sound like a good thing. I don’t know whether it’s supposed to reboot itself when it loses WIFI. It sounds like we might have 3 possible issues:

  1. It's losing it's WIFI connection.
  2. It's not getting reliable power.
  3. It's defective.

The easiest to test for would be reliable power. Do you have an extension cord that you could use to temporarily power it from a different receptacle to see if it still reboots regularly?

If it’s defective then it’s covered under Liftmaster’s warranty so we can replace it. These things aren’t normally a nightmare to enroll.

We’ll do some digging tomorrow to find out more about whether the rebooting necessarily indicates a problem. If you can provide any more information about when it’s rebooting that would help. Like is it rebooting at regular time intervals? What’s the longest and shortest duration you’ve noticed between reboots? Can you verify that viewing the status page doesn’t “cause” a reboot. For example if you check the status page and then check it again 5 minutes later, make sure the “Powered Time” is longer than 5 minutes.

We’ll get this figured out.

You would work with us to get it replaced if it’s defective.

Liftmaster reps were immediately confident that it is a defective unit given the rebooting issue. It does have a sleep mode, but should not reboot itself. The unit will need replaced.

See this page for returns forms and info regarding warranty policy.

The garage is brand new and all electrical is new, the MyQ shares a receptacle on a dedicated circuit with the garage opener.

The device has continued to reboot itself, the longest “uptime” I saw was ~2 hours…but I have also seen it reboot much more frequently. I am glad to hear that the warranty is handled by Surety, as I had actually tried contacting LiftMaster and they told me to contact even though I explained that the device was rebooting itself.

I will contact you guys during business hours tomorrow to process the return and replacement.

Everything you need in order to start the return process is available here , including the form with which to return/exchange the defective item.

I ordered a replacement MyQ and installation was pretty smooth this time, other than ADC wanting me to do the entire setup through the web site rather than manually on the device. I was able to get it added back though, much less painful than the first time getting the MyQ installed.

It seems the firmware on the device must be different, it no longer has a web interface where you can monitor status…so I cannot monitor for “uptime” to confirm it isn’t rebooting. I guess we will just have to see if the problem repeats itself or not.