Adding a CT80 Thermostat

I am trying to add a Radio Thermostat CT80 to my 2GIG GoControl 2 panel. I have the USNAP ZWave module installed in the CT80. My panel has the 1.10 firmware.

When I first tried pairing, it seemed to work just fine - the GoControl recognized the themostat and my thermostat features were enabled on the panel and on I could see the temperature reading from the panel on But, it’s not clear the panel was ever actually responding to commands from - it didn’t change when I told it to change the temperature. After a while (maybe an hour or so?) it stopped updating, and the website reported a device malfunction. I was able to re-pair it, but it’s not updating - on the panel when I try to access the thermostat it just says “acquiring ZWave device status” and then times out.

Is there a trick here? Is the CT80 compatible with this setup as far as you know?

Any help is appreciated -

The CT80 with a Z-Wave USNAP module should work with 2GIG and I’ve never tried it myself, and I doubt very many have due to the price and limited availability, but it should work. I’ve heard that people have used it before.

How close is the thermostat to the control panel? Are there significant walls in between? Could it be a communication issue that a Z-Wave repeater might solve?

Unfortunately they are close together - about 15 feet, line of sight in the same room.

What diagnostics can I give you? I’m happy to be a guinea pig - I already ponied up for the thermostat and installed it so I’m motivated to get it to work.

I think this is going to require some help from 2GIG to figure out. We’ll probably have to wait until business hours to get much further.

No problem Ryan. I appreciate your responses on a Saturday.

One more clue, not sure if it’s useful - please see the attached photo of my CT80 screen. It tells me “Radio 2: Empty” and “Network: None”. But it lets me “mate” it anyway. You can see that it let me select radio 2 because the icon is darkened - I cannot do the same for radio 1. Anyway, I have no basis of comparison so I don’t know if this is normal.

In order to further troubleshoot this, a few extra pieces of info are necessary. They should be able to be gathered rather easily at the thermostat.

  1. The necessary firmware of the thermostat (not the alarm panel) is 1.09 or higher to be compatible with zwave. You can check this by turning your mode to “off” and pressing the lower left corner of the thermostat screen to display the firmware revision and module revision.

  2. There is also a limitation of versions of the CT80 thermostat where it appears an A version or B1 version may not be compatible. The B2 version of the CT80 is required. This should also be displayed on the screen when you follow the previous steps. If not, it might be found on the product sticker on the thermostat. This is a manufacturer’s designation which will likely be tied to the shipped firmware version.

If you have trouble finding any of this info, please try to attach a good photo of the product sticker and serial number, we should be able to narrow it down that way.

Weren’t the CT80 tstats replaced by the CT100 tstats (or do I have it backwards)? I know 2GIG uses the ct100, as well as Lowes store iris brand…

eBay has the ct100 new for $80, and Lowes (under the iris brand) has them for $99

CT30 was replaced by CT100. CT80 is a higher end thermostat that has more features like humidity control.

Thanks Jason. I’m traveling now and away from my thermostat, but I will definitely get this information when I get home later this week.

Hi all, here’s the information I was able to get:

CT80 version: 02.34T
ZWave radio version: 07.41
S/N: 10 09 007737

Also attaching pics for your viewing pleasure.

I didn’t see a hardware version number, but I didn’t have time to unmount the thing from the wall this morning - let me know if there is another sticker on the back that I need to see.

Word from the manufacturer is that what you have is an A version of the thermostat, but that the zwave module is a version that is compatible. So the interactivity of the module with the thermostat should be fine.

When you pair the thermostat with the panel, do you see the word “Link” show up on the thermostat itself? This would be located directly underneath the radio tower symbol. It is important that “Link” shows up as it indicates the thermostat has recognized the network that has added it.

Also, did you ever use the “Remove Zwave Device” command on the Go Control panel? Or did you try to only add it again with the same result? If a device is associated with a network, it must be removed from all networks prior to properly accepting a new one.

Jason, thanks for reaching out to the Radio Thermostat guys.

My recollection was that it did say link, and I did try to remove it before re-pairing it. To be sure, when I get home I will remove it (if it is showing up) and re-add it, then report back on whether “link” appears.

Thanks again.

Ok, here’s the scoop.

  1. The thermostat does say “link” on the screen under the radio tower icon (see pic #1)
  2. The GoControl panel does recognize the thermostat (see pic #2)
  3. When I try to access the thermostat details on the GoControl, it says “Acquiring ZWave Device Status” for a long time and eventually times out (see pic #3)
  4. When go into “Remove ZWave Devices” on the GoControl, it says “Discovering ZWave devices” for a long time and eventually times out (see pic #4)

Net result is it seems like the thermostat is paired, but it’s not working and I can’t remove it. It’s still showing up on my page as “Low battery, malfunction” but does not update in either direction.

What else can I try?


I apologize for the prior lack of clarity, when removing devices, you’ve correctly done the steps at the 2Gig panel, but need to follow the same learn process at the thermostat as when you added it. So, to remove a device, you would press remove devices on the Go Control panel, then perform the pairing process at the device.

Have you done this already and the 2Gig panel simply did not recognize the device was being removed? If not, I would recommend trying this.

I would actually recommend whenever any zwave device is installed to just perform the remove function first, as quite often they are likely tested by manufacturing and never removed from the test network, in which case they will not function on subsequent networks.

Got it - no, I did not attempt to remove it this way, will try that tonight! Thanks!

Status report - I was able to remove the thermostat from the ZWave network using the steps provided. I am then able to re-add it to the panel by going to “Add ZWave device” on the panel, then hitting “mate” (twice?) on the thermostat. The panel successfully detects the thermostat. The thermostat then says “link” on the screen and shows up under “thermostats” on the panel, but when I try to access it there it says “acquiring ZWave device status” until it times out. Likewise, recognizes that I added a thermostat but after a few minutes it notifies me that the thermostat has malfunctioned.

I tried rebooting the thermostat and the panel after removing and before re-pairing, but no difference.

The ZWave “node” number for the thermostat increments every time I remove/re-pair the device - I assume this is expected.

What else can I try?

Thanks again.

Yes, the Z-Wave node number incrementing is normal, even when you remove and re-add the same device.

As far as I can tell in reviewing this topic it sounds like it’s either an incompatible version or defective hardware. It might be worth returning and specifically requesting version B2 instead of A. I’m a little confused that first they said you need version B2 and A may not be compatible. Then they said you have version A but it is a compatible version. If they replace it with a new version B2 that would address both possibilities. The other thing to keep in mind is that the Z-Wave radio is in the USNAP module not the CT80 so if the problem is Z-Wave communication then it could be a defective USNAP module. I think I would replace the CT80 with a new version B2 first and if that doesn’t work then replace the USNAP module. Although I’d wait until Monday to check in again with the manufacturer just in case they have any other ideas before exchanging.

Update: I got a hold of Radio Thermostat, they were vague on whether the version A would work with Z-Wave or not, and didn’t want to speculate on whether the CT80 would actually work with the GoControl. In the end they told me they couldn’t help me and I had to talk to 2GIG.

I then talked to 2GIG; they asked me to unpair/repair like we had already done, and if that didn’t work my only option was to return the thermostat.

I’ve been in the middle of these interoperability finger pointing sessions before as an end user and don’t anticipate a favorable outcome. Unfortunately I’m also well past my return period at this point. Before I give up and put the thing on eBay are there any other options that you see?

It should be a 30 day return window on Amazon. If not, won’t Radio Thermostat exchange it for a version B2 to give that a shot?

Here’s a possibility that was suggested by one of the most helpful people at we’ve been talking to about this issue. A known issue is described by Radio Thermostat in this PDF file.

Based on your radio version being 7.41, that means you have 7.4 firmware and your thermostat was added to the Z-wave network as a wall powered device (with the C-wire). So it’s possible that you are experiencing this issue. If so, the work around is to add the thermostat to the Z-Wave network as a battery power device instead. You can still reconnect the C-wire afterward and power it from the furnace. The only down side is that the thermostat won’t act as a repeater on the Z-Wave network because it was added as a battery powered device. It seems like it’s worth a shot.

Issue Description
There is a known issue with v7.4 of RTCOA Z-Wave firmware that will cause thermostats to constantly transmit on the Z-Wave network. This constant transmit condition will cause communication failures not only with the thermostat itself, but other Z-Wave nodes in proximity to the thermostat. This issue has been known to occur only on thermostats joined as always listening devices (c-wire) with moderate to large z-wave networks. This race condition is only present in v7.4 and has been eliminated in all subsequent firmware versions.

If the user suspects that the thermostat is in this state because of network communication failures, reset the thermostat and check the Z-Wave network again. If Z-Wave network communication is restored, then issue is the likely cause of the communication failures.

This issue only happens on thermostats powered via the c-wire with a Z-Wave USNAP module v7.4.

Work Around: Instructions to join thermostat as a battery powered device

  1. Exclude the thermostat from the Z-Wave network.
  2. Turn off HVAC power.
  3. Disconnect the C-Wire.
  4. Reset the thermostat and wait 10 seconds.
    1. The reset button is located underneath the top wire cover.
  5. Include the thermostat to the Z-Wave network.
  6. Verify that the thermostat has successfully joined as a battery-powered device.
    1. The radio version should say ‘7.40’.
  7. Reconnect the C-Wire.
  8. Restore HVAC power.

How to determine Radio Version and C-Wire/Battery Status

  1. Put thermostat in OFF mode.
  2. Press and hold lower right corner of LCD for 5 seconds.
  3. Text will appear in the upper left corner of the LCD. This text area displays the thermostat firmware version and the firmware version of the USNAP radio modules. Press the up or down buttons on the LCD to cycle between the versions.
    1. Fx.yz : Thermostat firmware version (e.g. F1.92 is thermostat firmware version 1.92)
    2. L z.yz : Firmware version of left USNAP radio module (if present)
    3. R z.yz : Firmware version of right USNAP radio module (if present)
  4. The last digit of the radio version represents the c-wire/battery status. If the digit is ‘1’, the thermostat is mated with c-wire. If the digit is ‘0’, the thermostat is mated with battery.
    1. ‘7.41’ : USNAP v7.4, mated with C-Wire.
    2. ‘7.40’ : USNAP v7.4, mated with battery.