35 degrees on thermostats

Hi all,
I have a GC3 panel with three Smart thermostats and two remote temperature sensors. I’m finding that the panel frequently shows the set temperature of one or more of the thermostats as 35 degrees while the app sometimes matches and sometimes does not. (I never set it this low - it’s below my minimum). I also have frequent trouble controling the thermostats from the panel - sometimes I can’t change the temperature off 35 or the options to change the mode are graded out, etc. Thoughts on how I can rectify this odd behavior?

Thanks,
Tom

have a GC3 panel with three Smart thermostats and two remote temperature sensors

RT sensors Not compatible with GC3 . For more info on this, see: https://suretyhome.com/forums/topic/alarm-com-temp-sensors-and-gc3/#post-47187

Quote from Jason @ Surety Feb,22, 2016

As I understand currently, the RTS is not yet fully compatible with the GC3. In fact, I believe it is only compatible at this time with the GC2 (and specifically, the newer hardware version of the GC2 [running zwave 3.42], an older panel model that has had firmware upgraded will have issues due to older [2.78] Zwave version)

I’ll see if I can get some more info today on where that RTS compatibility is in the list of to-dos for 2GIG and the GC3. It certainly will be at some point, but currently it is not compatible as I understand it.

Also, Z-wave version of 4.5X is needed for NWI and RTS. Original quote did not specify.

[GC2] Z-wave version of 4.5X is needed for NWI and RTS

4.55 replaced 3.42? What firmware version panel release was this (1.13 or 1.14)? My panel is only alittle over a year old, and released with 1.10.1. I assume a 2015 release?

Can I get a screenshot of the inside of this new hardware panel? I am trying to document all GC2 hardware versions

moved new thread here: https://suretyhome.com/forums/topic/2gig-gc2-and-adc-t2000-rts/