2GIG-SP1-GC3 stuck on wireless menui


I have a 2GIG-SP1-GC3 that I just recently updated to firmware 3.1.2. When the unit boots I go to the wireless menu and there is no way to get to the main menu (no navigation buttons on the main screen, and pressing the two buttons on the right have no impact)

Before the update it connected to the main panel reliably. After the upgrade I had no issues for a few weeks, now when the SP1 boots up it goes right to the wireless connection screen. The wireless button is enabled and the Wired and Pair buttons are disabled. The top status bar says “Device connected and paired with a control panel”. If I go in to the wireless menu I have the option of forgetting and reconnecting to a wireless network which I have done. I have also rebooted the system by unplugging and removing the battery, plugging back in after ~10 minutes. I have also tried holding down the two buttons on the right and the display does not change.

Any ideas?


Have you tried connecting to the GC3 via Access Point mode? Not a permanent fix, but should tell us if the SP1 can still connect or if it might be a simple bug or network issue.

Try going to Network Settings on the GC3 and turn on Access Point mode. Connect the SP1 to the GC3 network. Any luck?

If you try to reset using the buttons, be sure to press on both buttons at the same time and hold for 20 seconds

After holding both buttons down for 20 seconds, it did open up the pairing button. Going to the GC3 and pairing the SP1 button, they do not pair. Says sending signal from SP1 and listening from theGC3 but nothing happens. Checked and both are on the same network. Refreshed both WiFi and still nothing.

It looks like the GC3 in question is on 3.1.2 firmware. What version is on the SP1? Try upgrading the firmware via USB drive on both to 3.1.3, then try the pair process again. Any luck?

The SP1 uses the same firmware files as the GC3. 3.1.3 release notes indicate that connectivity issues were addressed.

OK, I figured out how to download the 3.1.3 software and updated both the SP1 and GC3 panel. Still don’t communicate. The SP1 says not connected and does send signal. The GC3 says listening. Nothing else happening

Just to be sure, begin the pair process on the GC3, then press Pair to Panel on the SP1 after the GC3 is already listening.

If you are already doing it in that order, try setting the GC3 to access point mode:

Settings > Installer Code > Network Settings > Wireless > Forget Network

Then Settings > Installer Code > Network Settings > Access Point > Enable

Connect the SP1 to the GC3 access point network. Any luck?

I tried using the access mode. The SP1 picked up the info from the GC3 but when I tried to pair, got the same results

After you go through the process above and connect the SP1 to the GC3 access point network, can you post a photo of the SP1 screen when you tap Wireless on the SP1? Are you still seeing “Authentication Problem” ?

Does this mean there is a malfunction in the wi-fi module in my SP1? It can receive the Access Point when both are enabled, but can’t transmit either via the household wi-fi or the access point wi-fi.

No. I get Device Connected but not Paired and the wi-fi and pair boxes highlighted.

I get Device Connected but not Paired and the wi-fi and pair boxes highlighted.

That would be on the main home page. Please tap “Wireless,” what do you see written under the SSID name you’ve tried connecting to?

Does it say “Connected” or does it say “Authentication Problem” ?

The home page will say “Device Connected but not Paired” for either status.

I get

Setup Auto
I get the IP Address, Subnet Mask Gateway and DNS Server.

all categories filled, but faint

going back to the wireless, it says connected to the 2GIG GC3

To clarify, looking at the equipment, I see an SP1 listed, with an installation date of 6/30/2018. This means the panel shows it hasn’t been deleted from panel programming. Are you using a second SP1 or is this the same SP1?

Did the SP1 work fine previously? What prompted you to reset the SP1?

If you are trying to relearn an SP1 which was previously in the GC3, be sure to delete the peripheral SP1 listed in the GC3 programming menu first. This would be under Settings - Installer Toolbox - System Configuration - Keypads.

This is the original and only SP1. It worked well for at least a month. One day realized it was no longer working so having been working on it since. The GC3 shows the SP1 and serial number etc. when trying to pair.

i got it to pair by going back to the GC3 and listing the SP1 as existing. seems tobe working now

We’ll do some testing to see if we can replicate but glad to hear you’ve resolved the issue!