2gig GC3 Touch Screen Not Responding


I just received my order today for a GC3. When I initially powered it up the touch screen worked but after about 10 seconds it is no longer responding.

I pulled the back up battery plug out then unplugged it from the power source. I then plugged the backup battery back in then plugged it into power source, unfortunately it still wont respond to touch.

Please advise on what steps should be taken to get the screen responsive to touch.


When you say it won’t respond to touch, is the panel not rebooting after the power cycle Or is it powering on and the screen is just unresponsive?

If it isn’t powering on, you may want to ensure that the transformer’s wires are attached correctly and have not come undone. Check the both ends of the wire to ensure that they are firmly attached.

It powering on fine. The screen is unresponsive to touch. Hardware buttons on the right work fine.

We do see signals coming from the panel which is good. If the screen is unresponsive, try powering down the panel (unplug Power Supply then battery) wait about ten minutes then power the panel back up (Plug in battery first, then Power Supply) Any Change?

If not, power the panel down again as above and this time remove the cellular Module Sled. (pulls out from side of panel, hidden by a plastic cover) wait 2 minutes then power back up again without the cell sled attached. While the panel will no longer communicate, we are looking to see if the screen is responsive after this.

Hi Tyler,

Powering down and waiting 10 minutes seemed to do the trick, touch is working now thank you.

One last question:

Is there a way to change the voice announcer “Front Door” to just a chime?


Glad that worked!

To change the chime of a sensor start by clicking System Settings ->installer code -> Installer Toolbox-> System Configuration -> Wireless Zones. Highlight the zone in question and click Edit Zone. Finally, scroll down to the Sensor Chime field and select the chime type you want. When done click Return to System Configuration and then the arrow at the left of the screen. You should get the option to save or re edit your changes. Click save when ready and you’ll be set.