ZTS-110 Thermostat will not pair to Qolsys

Looking for some suggestions here, I’ve tried every sequence I can think of:

  1. Exclude the thermostat first (the qolsys never acknowledges that it was included).
  2. Attempt to include the thermostat
  3. Thermostat registers as on the network in it’s display panel (‘done’ and the Z wave symbol appears)
  4. Qolsys pairing times out without ever acknowledging/pairing to the thermostat.

I’ve reset the thermostat to factory default twice now.

The IQ panel and the thermostat are within 1 ft of each other during these attempts.

Any suggestions would be most appreciated - thanks

That is strange, considering the ZTS-110 is the same as the Qolsys branded thermostat I believe.

If I had to guess, I would say it is acting as though the Qolsys panel is not accepting it due to a command class mismatch (thermostat presenting itself as a type of device the Qolsys panel does not recognize), considering the thermostat thinks it has registered to a network.

Just to make sure it isn’t something silly, can you check under Settings - Installation - Home Control Settings and see what your current maximum number of thermostats shows?

Have you successfully added other devices to your network?

Thanks for the reply - I confirmed that the max number of thermostats is currently set to 5. I have been able to successfully pair five locks to the panel so far without issue.

Well it sounds as though you have already done the standard troubleshooting otherwise. I have sent the issue to Qolsys to look at. I should hear back today.

Can you provide any hardware revisions or version numbers for the thermostat, maybe the serial number? It may help narrow down the issue. If it is easier, it may be best to attach a photo of the serial label.

I can get that information this afternoon and upload a photo as well.

From Qolsys:

We don't normally recommend a factory reset to troubleshoot pairing issues. I would first try Clear Device and clearing the thermostat the same way you do the pairing process. You will know it is clear when the wireless symbol is gone from the display. Then add and pair the device the same way (hold home button for 3 seconds then press program button).

The panel will get the clear and announce “device cleared from network successfully” so you know it is communicating to the radio.

If that process does not work for some reason, try Remove All Devices and start the process of clearing and pairing over again.

To confirm, they are suggesting I remove all devices from the IQ control center and then reconnect everything? (it’s only 5 locks, not the end of the world, but still…)

Also - I noticed the following screen (image 1) from my alarm.com account - clicking the ‘contact us’ url takes me to a support ticket creation screen (image 2) - is there a setting that needs to be enabled from your/alarm.com’s side for thermostats to pair successfully? Should I go ahead and create a ticket?

No, those tickets would just be more slowly redirected to us.

There are no additional settings. Thermostats are enabled on the account.

When you perform the remove device function, does your Qolsys panel announce that a device has been removed?

Normally it does, but not with the thermostats. I just completed the following steps with no luck on pairing the thermostat:

  1. removed all devices from my IQ panel
  2. performed exclusion steps on the thermostat
  3. attempted to pair thermostat to the panel

the IQ panel reacted in the same manner as before, it timed out in the pairing process without seeing the thermostat. the thermostat thinks it is on the network and shows the correct symbol as well as indicated it was ‘done’.

What should I try next?

Are you able to take that photo of the product sticker?

It sounds like an issue either with the thermostat radio, or compatibility. Are you certain this is a ZTS-110?

Also - here are pictures of the device and wiring (note I have two of the same model and wired the same way).

It’s important to note both thermostats are controlling the HVAC system correctly.

Wonderful. Thank you. Well that makes it even stranger. I have updated Qolsys as well.

Both of the thermostats are exhibiting the same behavior?

Can you report your current IQ firmware version? Select settings, installer code, select About. It will be listed as the software version.

That’s correct - both thermostats are exhibiting the same behavior.

The firmware version is Q1.4.2-ADCS 4.1-ADCL 4.1

just in case - photo attached

Is the Qolsys panel running off of battery when you are trying to add the device? Or are you powering the thermostat on battery and bringing it to the panel?

It may be that the Zwave radio is not receiving enough power to transmit properly.

A few additional things to try:

Reverse whichever device you’ve brought to the other. If bringing the panel, are you able to plug the panel into a receptacle nearby the thermostat to make sure neither are running off batteries at the time?

Try disabling and re-enabling the Zwave radio (in the “settings - home control settings” menu)

Try rebooting the panel and then adding the device.

…I’m embarrassed to admit that a panel reboot did the trick - both devices are now successfully paired to the panel. Can’t believe I didn’t try that earlier.

Thanks for all the help!

As long as it ends up being something easy, that’s a win.