z-wave devices not on ADC since adding smartthings with 2GIG

Trying to use a primary controller (smartthings 2.0) and a secondary controller 2gig panel, and now that I joined all the zwave devices to the smartthings, I am no longer seeing them in alarm.com (even though they are showing up on the 2gig panel).

Is there something I need to do in order to get the devices to show back up in alarm.com to be able to be controlled by both alarm.com and the smartthings hub?

So you are able to view and control the devices through the 2GIG panel currently?

You followed steps similar to those shown here?

An equipment command failed to show any new devices, have you done troubleshooting and since removed them?

Hi, thanks for getting this pushed over to the forum.

Yes I followed those instructions in the thread and reset the controller a few times last night.

I have everything added into smart things, they are all showing up on as devices on the 2gig panel, however they are not showing in ADC at all.

I did not, however, take the ST hub to the 2gig panel. They were both in their installation locations. I will be out of state this week, but can try that when I return next week.

They are still added in my smartthings hub, and before I left this morning, they were still showing up in the 2gig devices list (and 2gig was still a secondary controller).

Proximity is almost always a necessity with Zwave. When you get a chance, reset the 2GIG controller, remove it from and then re-add as a secondary to your Primary Controller within a short distance. Leave the two near one another for a few minutes. You can send an email to customerservice@suretyDIY.com to request an equipment update to see if the devices in the 2GIG panel are now visible.

I reset the 2GIG, removed it and re-added as secondary to the Smartthings controller from about 1 foot away. I sat there for about 5 minutes and saw the devices all show up in the 2gig controller. I then sent an email to have customerservice do an equipment update. The devices still are not showing up in ADC.

You may have found an incompatibility.

One thing, it looks like this panel is running 1.10 firmware. May be worth a shot updating to the most recent 2GIG Go!Control Firmware.

I believe others have this working with smartthings…just not sure about smartthings 2.0.

I will give the firmware a shot. Any other troubleshooting tips I could try?

I would say firmware should be #1 step.

If you are successfully seeing and can control devices from your 2GIG panel, I can’t think of another issue at the moment (barring communication, which is not the case, all signalling looks fine)

Updated the firmware, reset and tried again. I submitted an email for an equipment update, but haven’t heard back yet. Nothing showing up in ADC.

It sounds like others have this working so I’m not sure what is going on.

Can you provide a couple links to the people who say they have this set up functioning with Smartthings 2 and ADC?

Some reference to others working:

Hmm. Are you able to post a screenshot of the 2GIG panel listed as a controller in Smartthings? I’d like to see the interface and how it reports. Perhaps an image as well of part of the device list on the 2GIG panel?

I don’t doubt you have that part working, but it would be helpful when discussing with ADC to have that visual aid.

Here are some different screenshots of both:

Let me know if they are not clear. I think a couple got mixed up out of order.

On the 2gig, smartthings shows up as “PC Controller”.
The static controller is the 2gig. I’m not sure why it’s showing up twice (with one being yellow).

Hi Jason,

I just came across this old thread that you were helping someone else in regarding a similar issue (with Vera, but same issue).

Do you know if there was ever resolution to that?

Devices show up in ST/2gig, but don’t make it to alarm.com.

I’m going to go try the cell test, and may try removing a device and just learning it to the 2gig to see if that pushes through to ADC.

We didn’t receive any follow up from that user about whether they eventually got it working so we’re not sure. We’re working with Alarm.com to help resolve your issue though and hope to have some additional info soon.

Thanks, appreciate it!

Any updates from ADC on this?

No update yet but it is being looked into. This is definitely an edge case for them. Not many use their 2GIG panel as a secondary controller and the ones we’ve worked with in the past were Vera, not SmartThings. I’ll keep you posted as I learn more.

Same exact thing was happening to me. I was excited to pair all of my z-wave devices to SmartThings, and use 2Gig as the secondary controller with similar functionality, only to run into the issue of none of my devices showing up in ADC. I can confirm the devices show up in the 2Gig panel though. One odd thing I noticed was that a few of the devices were highlighted yellow in 2Gig (including the controller), while they were all good in Smartthings.

I opted to go back to using 2Gig as primary until the integration is improved.

I’ve seen some similar issues with the yellow devices, but they still seem to work fine.

I’ve contemplated going back to 2gig, but now I have the Amazon echo working with my smartthings and don’t want to give up that functionality! Until this is resolved, I’ve lost the ability to trigger lights and other rules from using the alarm’s motion sensors, trigger disarm when unlocking, geofence thermostat and thermostat schedules.