XCVR3 installation

I recently purchased and received a XCVR3-GC3 and Image2 sensor for my GC3, after installing the transceiver adapter and then trying to add image sensor via system configuration/wireless zones I am unable to “Learn Device” in during the system configuration.d
My GC3 has the software 3.0.1 installed
Transceiver seems to be wired correctly
Register module and test were done after power up it was communicating with ADC
I purchased 2 Image Sensors and tried both and neither would learn…
Any ideas how to test the transceiver adapter to see if it is working properly?

I discovered that the GC3 does NOT have correct firmware
Can you go over how I download latest firmware from your website
It only downloads as a .htm file which will not upload to the GC3 through a USB drive.

Try using a different browser to download. I found it wouldn’t work with certain ones.


Just to make sure, you are using the links found here to download the firmware?

What browser are you using?

Warren, with Internet Explorer 11, clicking on the link for 3.02 shows a screen with garbage characters. Besides myself, I’ve seen at least two other forum members not be able to download with that link using one particular browser or another. I was able to get it to download properly from an iMac using Safari.

Bye the way, tried the link for 3.01 and see the same issue with IE11.

I think the download link needs to be fixed somehow. Perhaps the file extension is being recognized as an executable file or something, not sure. Perhaps zipping it will help.


I am using a PC with WIN10 and tried both IE11 and EDGE and got a screen with “garbage characters” just like Dino.

Those links are direct to 2GIG downloads. Looks like I am seeing the same on IE and Edge.

I can confirm Chrome and Firefox both work fine.

I’ll notify our team to resolve the IE and Edge concern and we’ll update here.