Thermostat control

I am unable to edit the heating schedule for 2 CT100 thermostats. When I check Schedule On and click the set button I get an error that the page cannot be displayed. This started happening after I removed the 2 thermostats from my 2GIG panel and then added them back to my system (they have not been following the schedules). I can change the set points from the web page without issue.

I’ve had ADC send a couple refresh commands for the schedule, but the error message is not something I am familiar with. Were you using the app or the web site to turn on the schedule? What browser were you using if web?

With a little more testing I determined that I can change the mode and turn the thermostat off and on as long as the schedule is turned off. With the schedule turned on it fails every time.

To clarify, does attempting to turn the schedule on cause the problem? Or while the schedule is on, you cannot manually make changes to set temp and mode?

From the website (using Chrome browser on a Mac), if the schedule is off and I check Schedule On and then click Set I received the error message. Now I don’t get that far. I can click the emPower tab and see the 2 thermostats under devices. If I click Thermostats I see the following error:
Sorry, the page you attempted to access is temporarily unavailable.
We apologize for the inconvenience.
Please wait 2 minutes then try your request again.

I can control my security system from the web without any issues
I also tested in IE8 on a Windows 7 machine and see the same error.

When I try to open the app on my Android device I get the following error:
There was an error processing your request. Please try again later. (Error code: 10)

I am not know if this is related to removing the thermostats from the 2GIG panel and re-adding them but I start having these issues later the same day I worked with the thermostats.


Interesting… I’ve never seen that one before. We’ll have someone with look further into it and should have an update for you tomorrow. Sorry for the inconvenience.

Counter-intuitively, it may be a good troubleshooting step to remove the thermostats again, leave them off the system for aa short while and verify they no longer show up in your account, then re-add them.

Is the windows 7 machine one that you have previously used to access ADC as well? A recommendation would be to clear your browser cache on both machines and try again. In fact, might want to give that a try first to rule it out.

I know it seems likely that the issues are connected, but to rule out other things could you delete the app and reinstall? Do you get the same error?

Here are the things I tried today in the order that I did them:

  1. Cleared cache in Chrome on Mac
  2. Logged in to ADC and could see the thermostats under emPower
  3. Clicked on thermostats and could view a thermostat. The schedule was on but the schedule display was missing the vertical bars that are used to modify the schedule. (see schedule.png)
  4. Turned schedule off and clicked set. Page refreshed without issue.
  5. Turned schedule back on and clicked set. Error page was displayed.
    UpdateScreen.png shows the display that appears for a couple of seconds after clicking set
    UpdateErrorMessage.png shows error message.
  6. Cleared cache in IE on Windows 7 and repeated tests. See the same errors.
  7. Uninstalled ADC app from phone and reinstalled. I was able to change security settings but receive error when trying to set temperatures. Error message: “There was a problem connecting to the servers. Please check your connection and try again later.”

Both thermostats throw the same errors.

It seems to me that there could be a problem with the schedule that is stored by ADC. I only see the error when trying to update the schedule (which I assume is updating a database on their site). Also, when I try to view the schedule the vertical bars are missing. Is it possible for ADC to remove or reset my schedule?



Counter-intuitively, it may be a good troubleshooting step to remove the thermostats again, leave them off the system for a short while and verify they no longer show up in your account, then re-add them

Removing the thermostats from your system and waiting for ADC to reflect the changes would be the quickest way to delete the schedules. Have you tried that? Sending a cell phone test afterward may push the changes up to ADC faster. Otherwise, we can sync them for you after you remove the thermostats, just let us know.

Thanks for your input. I ran out of time tonight to remove the thermostats but plan to try that tomorrow.

I followed your instructions for removing and adding the thermostats and everything is working now. I can see and edit my schedules and the thermostats are following the schedules. The Android app is working as well. Thanks for your support in resolving this issue.