System reset to default. Any way to recover?

I was adding a new CO2 detector to my 2GIG panel, and when I saved the config it took longer than usual to boot…and is now completed wiped to defaults. None of my sensors, devices, users, anything are in the config. Putting “how did this happen” aside for the moment, is there any way to recover from this (remote push previous config from Surety?) or I am just stuck reconfiguring the whole system?

No, unless possibly it has not yet communicated with ADC. If that is the case, you may be able to have a backup pushed. Remove cell module/Bridge.

IF THOUGH you look on and all sensors are already gone, then you are SOL, and will have to reinstall from scratch (I had to do this myself the other day due to bugs in firmware 1.14).

Thanks Riven. I looked on ADC and looks like I’m screwed.

Any clue why it would do this? I think I’m on 1.13.

And it looks like my Z-Wave devices are intact, it’s all the security sensors that are gone.

I would be happy to try pushing a back up for you, Ben. Will do so now. A word of caution, the back ups are periodically over written with current status. Give the system about 15 minutes to load those commands.

Amanda, I would really appreciate that. I understand that it might not work if it was already overwritten but at this point I have nothing to lose.

Thank you!

Just curious if this is expected behavior - about 15 min after you did the push, the panel went dark except for the “home” light is red. It has stayed that way for the last 90 minutes or so. Is it loading? Or should I be concerned?

backup restore only takes a few min or so.

starting to sound like your panel may be failing/malfunctioning. Unless panel was armed?

Well I went in pushed the buttons and that made it finish booting up. Still no security elements configured though. Thanks for trying Amanda.

I guess the main question at this point what is going wrong, and if there’s any definitive way to diagnose it before I just replace.

…when is the GC3 coming out again?

As an update, I did reprogram all my sensors (and made a spreadsheet with all the answers to the programming questions this time). I haven’t tried adding the CO2 detector that caused the problem in the first place (in retrospect I should’ve added it first).

It’s not normal for adding a new sensor to wipe out all your sensor programming. What model is the CO detector? Is it a different model than what you’re already using?

It’s very possible that the CO detector had nothing to do with the issue and a problem somehow occurred while the panel was trying to save the new sensor configuration settings.

It’s up to you whether you want to try to add the new CO detector again. You were able to add/configure sensors and save the settings if you manually reprogrammed you panel. I don’t see why the new CO detector would be any different. The CO detector shouldn’t have much of an impact on the panel itself during programming. There is no handshake or process where the sensor uploads information to the panel. If you know the sensor serial number you can program the sensor just as well when it’s not even physically present. All that’s happening is you are saving settings in the panel.

Your system currently shows it was backed up this morning at 12:15am with 15 sensors and your current firmware version is 1.12. Theoretically if the problem occurs again we could restore the backup but then again you said the last restore didn’t work. I can see yesterday’s restore occurring in the event history but I don’t see any errors reported.

Thanks for the thoughts Ryan. I tend to agree it was probably coincidental to the CO2 detector. Some followup questions -

  1. Should I update to 1.14? As I recall now I didn’t go to 1.13 because I wasn’t motivated by the features, but I will upgrade if there are relevant bug fixes.

  2. Can you give any more information on when the backups happen? That is, if I knew it happened once per day at 12:15am, I could plan around that. Of course, as you noted the restore didn’t take when we tried it yesterday. Any other way to handle backups (besides documenting all the config answers, which I did start this time around)?


There isn’t a specific bug fix listed for 1.13 or 1.14 about the issue you had. 2GIG has a tendency to only list new features and major bug fixes in their release notes. There are certainly bug fixes that don’t make the public release notes.

I recommend updating to the latest unless there is a reason not to, just to stay current and get any bug fixes and new features.

This topic is worth a read if you’re going to update to 1.14. It looks like downgrading from 1.14 to 1.13 wipes out your sensor programming. Most people would not be downgrading after they upgrade but it’s something to keep in mind.

There isn’t a fixed schedule when backups happen but we can manually trigger a backup if you want to make sure a backup occurs right before you try something.

Be careful with the panel backups. If you think you may need a backup restore, make sure the panel is not connected to ADC until such time as the backup is actually pushed. Otherwise, you may lose all your backed up data. (for example, say you ask for a backup, and then replace with a new control panel. If you connect that panel to ADC, before that old data backup is pushed, it may overwrite that backup with that new data (or lack of it as case may be), and now your old data is gone, and there is nothing to restore).

As for 1.14 there are some bug fixes (TS1 garbled voice announciation for one), but there are also new bugs (breaks Q45), and wipes out console settings, all Programming Q’s (including installer code and lockouts), user settings, and sensor zones if a different firmware version is flashed. Basically in a nutshell, reflashing another version of firmware onto a panel running 1.14, acts as a hard panel reset.

A couple thoughts regarding how it happened.

  1. Restore Defaults is an option in the Installer Toolbox. It would be pretty obvious if you went through the process, there is a confirmation screen so it is pretty impossible to accidentally do it.

  2. As unlikely as it seems, the face buttons on the 2GIG panel are physical buttons, and recessed. They can get stuck. I see it pretty often with older panels and the home button (gets used a lot). It might be possible (I haven’t heard of a case, but theoretically) that the two face buttons were depressed enough while handling the panel, and if pressed in at an angle or if worn/dirty from extended use, they may have gotten stuck while the panel rebooted. This would wipe settings (the physical default procedure)

the sticky button might also explain why he had that hiccup during the backup restore.

Thanks all. I will update to 1.14 when I get a chance.

I didn’t know about the physical reset procedure. Maybe a combination of things happened. Now that I think of it, when it rebooted, it “hung” with a blank screen and red home button for several minutes. I got worried about it and went over and poked the screen and both buttons, after which it finished booting. Perhaps I managed to trigger a reset. Anyway it was a valuable lesson learned.

I got worried about it and went over and poked the screen and both buttons, after which it finished booting.

This makes me suspect the physical reset likely occurred, because the panel will not boot back up until the buttons are released. Poking at them may have loosened them.

Check to make sure the two buttons are more or less flush with the front facade and not sunk in at all when at rest.