Rules & schedules not working

My rules and schedules stopped working. I have tried deleting all and recreating new rules, rediscovering network, etc. with no luck. Is there a way, can reset this?

Qolsys panel, right? VERIZON module…

Are you able to still remotely turn on/off zwave devices, remote commands executing within less than 30sec, or are you seeing significant time delays?

No, 2gig panel. I can remotely turn on/off z-wave devices with no significant time delays.

You should request ADC rules be repushed to 2GIG panel. Sometimes something goes wrong. I had a similar issue not long ago.

My understanding of the way it works, is any rules you create on ADC are then downloaded to 2GIG panel, and run locally.

Apparently those rules are not being downloaded, or are corrupted.

If your connection is intermittent, signals are not received properly, module is roaming, or there are excessive delays for remote commands to be implemented on panel, this could indicate a communication issue that may prevent those ADC rules from downloading to panel.

Verify Q79 is set to “3”

Delete all rules, wait a bit, then reboot panel, wait a bit, then recreate the rules on ADC. Then submit ticket to have rules repushed (if they still are not working correctly).


Thank you, I’ll try it.

Please avoid creating ADC tickets as a means of support. It is only a slower way to get your concern to suretyDIY.

From our response emails: “As a reminder, please post any technical support questions on the forum and direct all other questions to us by emailing or by Live Chatting us via the website ( during business hours. These ADC tickets are not always forwarded in a timely fashion and may cause delays in response to your inquires.”

In most circumstances, deleting and recreating a rule in will solve the issue. If this does not work, or if no rule is functioning by 15 minutes after creation, we can force a reconstruction of all rules.

As stated in the question above, I have tried that with no luck. Please advise next step.

Make sure the panel is not in programming menus and does not lose power. I will have those rules all resent momentarily. Please give 10-15 minutes then test.

Scheduled automation is still not working. Lamps set to come on and go off at certain time (example, at sunset) are not coming on as scheduled. I have deleted the rules, added them back, performed cell signal test. Very frustrating. What’s next? Thanks.

An additional command has been sent. Please check scheduled automation.

How many rules are working and how many are not? Are all event based rules working?

All event based rules are working. The two scheduled automations that I have currently are not working. I will try it now, since the additional command has been sent. Thanks again.

Event based rules continue to work. The two scheduled automations are still not working. I’m not sure what else to try.

It appears that time based scheduled automation is working, at least on the ones I have tested so far. I have both scheduled automations set to come on at sunset, which is not working.

I have looking into this issue. Interesting that sunset/sunrise is the one rule not currently working. By chance did you notice the rule take effect outside of when you would expect it to or did you not see the rule take effect at all?

Jason, thanks again for all your help. The schedules to come on at sunset never took effect.

It’s unfortunate this is the type of issue you can only test once per day. Additional commands were sent by ADC to make sure the network is communicating at 100%. This appears to be the case. Your rules have been rebuilt. Please let us know if you do not see the sunset rule take effect.

Let it go for a couple hours after if it does not, before changing any rules. I would like to rule out the possibility this is a timezone issue somehow.

Hi Jason. Whatever you and ADC did yesterday must have worked. The two scheduled events came on last night as scheduled and went off this morning as scheduled.

Thank you again. Take care.