GC3 zwave issues / FIrmware update?

I have had the GC3 running about 3 weeks now. . .

Have some issues with the z-wave devices (thermostat/lamp modules) I know there are “known” issues however, my panel has rebooted itself a few times and not responding to ADC commands from the app.

any idea what might be causing this? just hold out for the firmware update?


I am having ADC look into the history I am seeing on the account. Some strange issued commands regarding your Z-wave command buffer are going through. It looks like it may have to do with the temp sensors, (they are not compatible currently) but I am not certain.

Should have an update shortly.

THanks! :slight_smile:

Alright, looks like any Z-wave commands heading to your T2000 are instead flushing out your command buffer as the device is not currently compatible with GC3. The panel also appears that it may be rebooting if the buffer fills with inoperable commands.

In general, I would not recommend trying to use non-supported devices remotely.

Do you know when the T2000 will be supported fully?

any idea on time range for GC3 firmware?

There is no anticipated date yet on either of those, no.

2GIG likely won’t release info on it until the firmware is ready to push (might know a week before or so)

No information on what all is included in the first firmware update being worked on.

I just installed a new GC3 panel, having trouble linking Schlage Zwave deadbolt and door handle lock unit. Also, existing motion sensors and window sensors don’t seem to work either. Any ideas?

What are the model numbers of the motion detectors and the other sensors?

Only Kwikset was specifically stated to have full support on GC3 at first I believe, but just to be certain, are you learning them into the panel from within a few feet?

We have heard various degrees of success with devices which are not yet officially supported, so it may be a separate issue. If these door locks were used in a previous network, have you used the remove device function to clear them of their previous network link?

I figured out the motion detector issue.
As for the Zwave locks, they are brand new and never been used in a network before. I put the Zwave GC3 right next to the locks and thought I properly made them active for listening, but the panel didn’t even hint at seeing them. They are both Schlage, I bought them assuming they would work fine since in my old home I had an older 2gig panel and they worked perfectly.

Even if they are new, they may have been included in a test network.

Always try using the Remove Device function first.

If the panel does not recognize that a device was found (gives no indication at all) then this is likely the problem.

When I go to remove devices, it sees nothing.

What is the model number of the schlage locks? Are you performing the same link procedure on the lock after pressing “Remove Device” as you would when trying to add them (this is required)

The locks are:
Schlage Connect Camelot Touchscreen Deadbolt w/ Built-In Alarm, Aged Bronze, BE469 CAM 716
Schlage FE599NX CAM 619 ACC 619 Home Keypad Lever with Z-Wave Technology

Maybe I am doing the entire pairing process incorrectly. Can you tell me the correct way?

im using the Schlage BE468 Lock, with the GC3 without any issues.

What sequence did you do to pair them?

Sorry I think its the 369 (the one with buttons not touchscreen)

go the add zwave device, removed the batter cover of the lock, hit the zwave pair button and done!

do you have the
Schlage Connect Camelot Touchscreen Deadbolt w/ Built-In Alarm, Aged Bronze, BE469 CAM 716

or the

Schlage Connect Camelot Touchscreen Deadbolt w/ Built-In Alarm, Aged Bronze, BE469NX CAM 716

The Camelot version

Craig, there are different versions, w/ zwave and w/o zwave