Garage malfunction

Hi all,

I am using the Chamberlain Gateway with my older model Liftmaster garage door opener. Very regularly, I get the following email from my panel:

Home Alarm: The Chamberlain Gateway (33B8) reported a Malfunction at 7:42 am on Monday, June 1 2015.

This is a monitoring message from suretyCAM. Log in at to manage your system and view other recent activity.

I got a second email as well at the same time that just simply said:

Home Alarm: The Garage reported a Malfunction at 7:42 am on Monday, June 1 2015.

Everything seems to be working correctly, yet I get this email all the time. Any ideas as to why? Anything I can do to fix this issue?

Thank you,

It looks like a malfunction was reported for about 7 minutes today.

The two emails are referring to the two components of the system, the wall button (or door sensor with the wifi universal gateway) and the gateway.

What is the distance of the door wall button from the gateway? Have you noticed any internet connectivity issues?

Hi Jason,

The wall button and gateway are probably 5-7 feet apart, straight line of sight. There are no other internet connectivity issues, as far as I can tell.


How long has the system been sending malfunctions like this regularly? How often do you see them? Is there any pattern?

When you notice a malfunction and you are home, can you try sending a remote command to the door immediately to see if it will go through? Have you ever sent one before the malfunction ended?

I have been getting these for a long time…probably 6 months or more. No pattern - totally random.

I will try sending a remote command to the door next time and see if it works. I think I did it one time and it didn’t go through, but cannot remember for sure…so I will try again.

I will let you know what happens.


It would certainly make more sense for it to not go through. I only asked because you said the system was otherwise working fine.

Given the description I would hesitantly guess it is related to internet connectivity of the Gateway.

A good thing to check is actually the next time you receive the malfunction notification, take a look at the Gateway and its Green LED.

If the Green internet status light is off, your Gateway does not have an IP from your router. It may be possible you have a strange interaction with a DHCP lease period.

If the Green internet status light is flashing consistently, it means your Gateway has an IP but is not connected to the internet.

Thanks for that info. I will check it out and let you know. Have a great day!

Hi Jason,

The gateway reported a malfunction at 3:47am this morning. It was still in malfunction when I got up, so I checked the gateway - it had a solid green and a solid blue light. I sent an open command and it opened, but it sent an end of malfunction notice when I sent the command. I then sent a close command and it worked.

So, not sure whats going on.


Hmm, I’m hoping we can get a look at it shortly following a malfunction notification. I would still bet this is IP connection related. It sounds like simply receiving a status confirmation after you opened the door cleared the error.

When is the last time either the gateway or router were power cycled? I would try that and see if malfunctions come with the same frequency.

Would this likely be a DHCP issue with the router, or an internet connectivity issue? I can monitor internet connectivity to see if there are any internet dropouts around the time it reports a malfunction. If it is a DHCP issue, not sure how to easily monitor that.

I will power cycle both tonight and see if that makes a difference.

It may also be a good idea, since this has been going on for quite some time, to remove the Gateway from your account and re-add. Let us know if you would like to try this.

Hi Jason,

It seems to be in malfunction again. All lights are on.

Lets remove it from the account and then I will reset both the gateway and the router and then re add it to the account.


I have sent commands to delete it from the account. It looks like it has been successfully removed. Give a few minutes to make sure all commands are complete and go ahead and learn it back in when you are able.

There’s got to be something to this. I have the same combo and have recently been having the same issue (maybe about 4 months). Random notifications of malfunction. In fact it shows that way in my online interface right now although the gateway has the lights on and I’m able to open and close the door without issue. I’ve rebooted the gateway with no change.

There are multiple people reporting this. I will escalate the issue to It is possible the issue is with the MyQ database, which would explain why nothing resolves the malfunctions.

Hi Jason,

I had the opportunity to exchange my MyQ Gateway for a new one. I did that, changed the port on the switch to which it is connected and power cycled my router. It has been 4 days and I have not received a malfunction notice. Fingers crossed!!

Also, in my router, I had assigned a static IP to the Gateway. I have since removed the static IP and have the router assigning a dynamic IP via DHCP.

Unfortunately, with my all-in-one swap, I cannot be sure which of those steps may have actually solved the problem, but for anyone experiencing the issue right now, try removing and re-adding the Gateway from your account first. While it is off the account, reboot the Gateway and your router. Then re-add to the account and see if the malfunctions stop.

Thank you for the help, Jason!


Well let’s hope it continues without malfunction!

I would hazard a guess to say the issue is with MyQ servers and their communication with your Gateway. Removing and re-registering it will likely clear this if this is the case, so yes I would recommend trying that.